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License Terms and Conditions

Of the Helmholtz-Centre Potsdam – German Research Centre for Geosciences GFZ, a Public Law Foundation under the laws of the County Brandenburg, Germany,

Telegrafenberg, 14469 Potsdam, Germany, VAT ID No. according to § 27a VAT Tax Act: DE 138407750, Mail: igmas@gfz-potsdam.de (hereafter “GFZ”)

1. Scope of application

(1) These License Terms and Conditions (“Terms”) apply for the contractual relation between GFZ and entitled users which have registered following the

Registration process (see clause 2) (“USER”).

(2) These Terms govern the USER’s acquisition and use of IGMAS+-software in executable form, any updates as well as the respective documentation/user

Manual (”Software”) as provided by GFZ as download on the website www.gfz-potsdam.de/igmas (“Website”), e-mail: igmas@gfz-potsdam.de.

2. Registration

(1) The USER needs to register on the Website to be able to download the Software.

(2) There are two types of licenses from which the USER has to choose one when registering: a personal individual single-user license (”Personal

License”) and a group multi-user license (”Group License”). The scope of the Licenses is defined as license grant in clause 4.

a. The Personal License is issued to a single person and is non-transferable. In case the USER needs licenses for several persons, a separate

registration form needs to be filled in by each person or a Group License needs to be requested.

b. The Group License is issued to an entity like a research institute, a university or a company to be used by their employees as well as their onsite

working exchange scientists as entitled multi-users, but only for own internal research, educational or commercial purposes of the registered

entity.

(3) The USER is responsible for ensuring that his device meets the requirements to work with the Software.

3. Term, Termination

(1) The license runs for one year, starting on the day of submitting the registration form by the USER (see clause 2(1)), and is automatically terminated

after one year. To use the software after one year, the USER needs to request a new license again by new registration on the Website. The Software will

notify the User about the approaching end of the license in advance.

(2) Extraordinary termination rights for important reasons remain unaffected.

4. License Grant

(1) Depending on the USER’s chosen option at his registration (see clause 2 (1)), GFZ hereby grants the USER either a Personal License (single-user

for an individual, non-transferable) or a Group License (multi-user license for an entity; entitled multi-users are employees as well as onsite working

exchange scientists and guests of the registered entity).

(2) Personal License and Group License are non-sublicensable and non-exclusive. Both types of Licenses allow the USER to install and use the Software

in executable form by the USER himself (Personal License) or the USER’s entitled multi-users (Group License) on the USER’s devices under USER’s control

in accordance with these Terms, but only for own internal research, educational or commercial purposes of the USER.

(3) The USER is not permitted to:

• Copy, edit, alter, modify, adapt, translate or otherwise change the whole or any part of the Software except as expressly provided under this

license

• Permit the whole or any part of the Software to be combined with or become incorporated in any other software or create any derivative works

• Decipher, decompile, disassemble or reverse engineer the Software, in whole or in part.

• Reproduce, copy, distribute, resell or otherwise use the Software for any commercial purpose other than its own business purposes; the USER

is especially not allowed to sell or provide the Software to third parties.

• Use the Software in any way which breaches any applicable local, national or international law. The USER especially agrees that the Software

will not be shipped, transferred, exported, or re-exported into any country or used in any manner prohibited by the German Export Control Law

or any other applicable export laws, restriction or regulations.

Any attempt otherwise to copy, modify, sublicense or distribute the Software is void, and will automatically terminate the USER’s rights under this

Agreement.

5. Intellectual Property Rights, Citation

(1) All copyrights, trademarks and all other intellectual property rights in and to the Software, including any modifications, updates and upgrades made

hereto by GFZ and to all subsequent downloads of the Software by USER, are and shall remain the sole and exclusive property of GFZ.

(2) The USER agrees not to remove any copyright, trademark, proprietary rights, disclaimer or warning notice included on or embedded in any part of

the Software.
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(3) When the Software is used for generating results etc. for publication, the Software has to be acknowledged and cited as follows:

The results were produced using IGMAS+ software (Götze & Lahmeyer, 1988; Schmidt et al., 2010).

Götze, H. J., & Lahmeyer, B. (1988). Application of three-dimensional interactive modeling in gravity and magnetics. Geophysics, 53(8), 1096-1108.

Schmidt, S., Götze, H. J., Fichler, C., & Alvers, M. (2010). IGMAS+–a new 3D gravity, FTG and magnetic modeling software. GEO-INFORMATIK Die Welt

im Netz, edited by: Zipf, A., Behncke, K., Hillen, F., and Scheffermeyer, J., Akademische Verlagsgesellschaft AKA GmbH, Heidelberg, Germany, 57-63.

6. Maintenance

From time to time, GFZ may make available new versions or updates of the Software via a website as download, if and when those new versions become

available. Nothing in this Agreement shall oblige GFZ to develop such new versions or updates. Bug-fixes and new features are only supported for the

GFZ-executable version of the Software. GFZ is free to terminate the maintenance any time.

7. No Warranty, Disclaimer

GFZ does not warrant that the Software will function without errors or interruptions. The Software is provided “as is” without warranty of any kind,

either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose.

GFZ shall not be held responsible for the performance of or output obtained from the Software nor for any liability to any party arising out of use of the

Software.

8. Limited Liability

(1) GFZ is liable for willful misconduct and gross negligence. For slight negligence, GFZ shall only be liable in the event of breach of a material contractual

obligation (cardinal obligation), the fulfilment of which is essential for the proper performance of the contract and on the enhancement of which the

USER may regularly rely, as well as in the event of damage resulting from injury to life, limb or health or statutory liability.

(2) Any further liability, also for indirect and/or consequential damages arising out of the use or inability to use the Software (including loss of profit, loss

of data or data being rendered inaccurately or losses sustained by you or third parties or a failure of the program to operate with any other programs),

shall be expressly excluded.

9. Data privacy

The personal data collected from the USER is processed, used and stored only for the purpose of processing and executing the USER’s purchase of the

Software and the invoicing during the contract period (term) of the Software license. When processing the personal data of the USER, GFZ observes the

legal regulations.

10. Governing Law, Place of Jurisdiction

(1) This Agreement is governed by and construed and enforced in accordance with the laws of Germany. The application of the UN Sales Convention is

excluded.

(2) The Parties shall try to solve disputes amicably. If an amicably solution is not possible and a mediation is not successful, the exclusive place of

jurisdiction for all disputes arising out of or in connection with this contract shall be Potsdam, Germany.

11. Severability clause

Should individual provisions of this contract be or become invalid in whole or in part, the validity of the remaining provisions shall not be affected thereby.
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1CHAPTER

Introduction

“ You can’t blame gravity for falling in love.

”
Albert Einstein

1.1 Welcome

Dear reader, thank you for choosing IGMAS+ and welcome to the IGMAS+ User Manual!

You have selected one of the most comprehensive and well-known geo-modelling software for 3-D joint

inversion of potential fields and its derivatives under the condition of constraining data and independent

information.

This user manual is designed to facilitate understanding of the basic capabilities of the IGMAS+ software

and provide basic support. It explains how the powerful graphical interface of IGMAS+ can used be to its

full potential.

This version of the manual is a result of rigorous and painstaking work done by members of the IGMAS+

team over the years, inspired by the great demand for a detailed software description from the IGMAS+

user community. Please take your time to familiarize yourself with IGMAS+ and keep in mind that this

manual is written by non-native English speakers.
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1.2 Historical Overview

The software has been around for about 40 years, initially developed on a mainframe and then transferred

to the first DOS PCs, before it was adapted to Linux in the ’90s and finally implemented as a cross-platform

Java application with GUI called IGMAS+.

Starting from 2009, a consortium of national and international oil companies and the Norwegian Geological

Survey (NGU) supported the software development. The Gravity research Group at the University of Kiel

was coordinating the project and giving scientific input while the software company Transinsight (Dresden)

delivered the professional programming resources and support.

Java was chosen to be the programming platform to allow platform independency. The software has proven

to be very fast, accurate and easy to use once a model has been established. Later, the DGMK (German

Society for Petroleum and Coal Science and Technology) funded its research project number 771 entitled

“TiPOT3D - Towards an integrative interpretation of potential fields and corresponding gradients by the aid

of three-dimensional modelling and visualization” (Schmidt, Götze, and Menzel 2018) and supported the

software development on behalf of DEA, Deutsche Erdoel AG (Hamburg), EMPG (Hannover), ENGIE E&P

Deutschland (Lingen) and Wintershall Holding GmbH (Kassel).

Since 2019 IGMAS+ is maintained and developed in The Helmholtz Centre Potsdam - GFZ German Research

Centre for Geosciences by the staff of Section 4.5 – Basin Modelling and ID2 – eScience Centre. GFZ

headquarters are in the ”Albert Einstein” Science Park on Telegrafenberg in Potsdam, Germany.
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1.3 Main Features

1.3.1 Interactivity

Graphical interface in IGMAS+ allows adjusting the geometries and physical properties of modelled

subsurface bodies interactively, i.e. while the corresponding calculated and measured potential field

components are visualized together with independent observations.

1.3.2 Platform Independence

IGMAS+ is based on Java programming language which makes it platform independent.

1.3.3 Time Machine

In interactive modeling you have many data, which evolve over time, like model structure, physical

properties, current gravity/magnetic response of the model. Also visualization of fields changes over time.

In IGMAS+ we introduced the so called Time Machine, a timeline-based project management concept

which allow the user to go in time with the model and data.

The concept involves the project directory structure that keeps the valuable information about project

changes over time. In this way the user can always recover any model state.
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1.4 Feedback

Although the IGMAS+ software has been tested by many users worldwide, there can be still a number of

issues. We apologize for any inconvenience that IGMAS+ might cause due to unexpected problems, and

we want to hear from you in case of any issue that you might experience. This means that we invite every

user to become a tester in order to contribute to the further development, help us improve IGMAS+ and

design a user-friendly graphical interface as you want it to be.

This is how you can contribute:

Report errors and unexpected behaviour of the program with a brief description, and send it together with

a log file and a system report file (see Section 4.2.6.3 on page 34).

Share your sample data with us if you think that the detected problem could have something to do with

your inputs. We assure that we will use your data only for the purpose to solve the related problem,

and that we will delete your data as soon as the problem is solved.

Send us your ideas and suggestions concerning the user interface (menus, shortcuts, wizards), the

functionality, the default values or any other topic. Any comments related to the actual needs of

users are appreciated.

Point out errors, typos and inconsistencies in this manual, as well as topics which are out of date or wrong.

The appropriate section title will be marked as ”out of date” (o.o.d.) until updated. Missing sections

are denoted as ”to be added” (t.b.a.) until it is fixed. Accrodingly, incomplete sections are denoted

as ”to be extended”(t.b.e.).

Let us bring the IGMAS+ user experience to the next level together!

1.5 Contacts

Please send your feedback, suggestions and concerns (as well as log and system report files, bug reports,

manual comments etc.) to igmas-support@gfz-potsdam.de.

We hope that IGMAS+ will be an important contribution to your scientific work towards an integrated,

interdisciplinary interpretation of complex geological structures on the macro, meso and micro scale.

Sincerely yours,

IGMAS+ development team:

Denis Anikiev, Hans-Jürgen Götze, Christian Meeßen, Christian Plonka, Magdalena Scheck-Wenderoth,

Sabine Schmidt
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2CHAPTER

Software Package

“ Software is like entropy. It is difficult to grasp, weighs nothing, and obeys the second law of

thermodynamics; i.e. it always increases.

”
Norman R. Augustine

2.1 Requirements

Due to Java implementation IGMAS+ is platform-independent. So far it was tested on the following operating

systems:

• Unix:

– Debian Linux (32/64-Bit)

– Ubuntu Linux (32/64-Bit)

• Macintosh:

– Mac OS X (10.5 and above)

• Microsoft:

–Windows XP (32/64-Bit)

–Windows Vista (32/64 Bit)

–Windows 7 (32/64-Bit)

–Windows 10 (64-Bit)

2.1.1 Software

In order to install and run IGMAS+ the system should have the up-to-date versions of

• Java Runtime Environment

• Graphics card driver.
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2.1.1.1 Java Runtime Environment

Runtime environment is a common name for piece of software that is designed to run other software.

The Java Runtime Environment (JRE) contains the Java class libraries, the Java class loader, and the Java

virtual machine (JVM), as well as other components to run applications written in the Java programming

language.

The JVM is a program that has two primary functions: to allow Java programs to run on any device or

operating system (known as the ”Write once, run anywhere” principle), and to manage and optimize

program memory. The JRE creates the JVM and ensures dependencies are available to the Java programs.

Unlike a true virtual machine, the JVM doesn’t create a virtual operating system. There are many JVM

implementations, both open source and proprietary. HotSpot JVM is the reference, most commonly used

and the most thoroughly tested implementation.

The JRE is a part of Java Platform, Standard Edition (Java SE, formerly known as Java 2 Platform, Standard

Edition (J2SE)) – a computing platform for development and deployment of portable code for desktop and

server environments. One of the most well-known implementations of Java SE is Oracle Corporation’s Java

Development Kit (Oracle JDK). An alternative OpenJDK (Open Java Development Kit) is a free and open-

source implementation of the Java SE.

To avoid Java-related problems during installation and running of IGMAS+, it is recommended to use

AdoptOpenJDK 8 LTS implementation with HotSpot JVM or Amazon Corretto 8 implementation.

!
Due to Oracle Java SE Support Roadmap policy update (and particularly the end of free release updates

from Oracle after March 2019) it is recommended to use up-to-date OpenJDK Java SE implementations

(such as AdoptOpenJDK or Amazon Corretto) instead of Oracle Java SE.

On Windows systems just download the AdoptOpenJDK 8 or Amazon Corretto 8 and run the installer.

! Make sure to download and install the 64-Bit JRE (unless you are using a 32-Bit operating system).

On Linux systems the shell-command

$ update-alternatives --config java

shows you all available Java Environments and allows you to choose the active one. To switch the active

JRE, you will need root-permissions or you have to ask your system-administrator.

2.1.1.2 Graphics Card Drivers

It is highly recommended to use up-to-date driver for your graphics card.

Driver updates for Windows are automatically downloaded and installed through Windows Update.

To manually update the graphics card driver:

1. In the search box on the taskbar, type in device manager, then select Device Manager.
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2. Select the Display adapters category to see names of devices, then right-click the one you’d like to

update.

3. Select Search automatically for updated driver software.

4. Select Update Driver.

5. If Windows doesn’t find a new driver, you can try looking for one on the device manufacturer’s website

and follow their instructions.

Major manufacturer’s websites:

• NVIDIA®

• AMD®

• Intel®

To reinstall the device driver

1. In the search box on the taskbar, enter device manager, then select Device Manager.

2. Right-click the name of the device, and select Uninstall.

3. Restart your PC.

4. Windows will attempt to reinstall the driver.

Please refer to this page for more information on how to update drivers in Windows 10.

2.1.2 Hardware

Please follow the recommended hardware requirements for your specific operating system.

Minimum recommendations are:

• Processor: any modern Intel® or AMD® processor.

• Graphics adapter: 3D graphics adapter, preferably from NVIDIA® or AMD®.

!
Old Intel® adapters are known for rendering issues. We do not recommend to use embedded

Intel® GPUs.

• Memory: 2 GB or more

• Hard disk space: at least 500 MB free

• Pointing device: 2 or 3-button pointing device such as mouse or trackball is recommended. Touch

pad is also possible.

Depending on your IGMAS+ project size, higher CPU performance and/or more main memory (RAM) might

be desirable.
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2.1.2.1 Parallel Calculations with OpenCL™

For hardware-accelerated parallel calculations with OpenCL™, a compatible hardware (CPU, GPU) and device

drivers with OpenCL support are needed (compatible at least with OpenCL™ 1.0).

2.1.2.2 Stereoscopic Visualisation

NVIDIA® Quadro® FX series (or later) graphic adapter with support for Quad-Buffered Stereo and an

appropriate screen or projection installation is required.

2.1.2.3 Memory (RAM), Array Bounds and Heap Size

The Java code does not limit array bounds, so the maximum size of your model and the number of stations

you can use depend strongly on the size of the main memory (RAM).

! Exception: The number of voxel elements is limited to 10× 106 cells (see Section 5.8 on page 103).

The required memory are mainly defined by the following values:

• Number of sections

• Number of stations

• Number of bodies

When a Java program started, the JVM gets some memory from the Operating System. The JVM uses this

memory for all its needs and part of this memory is called java heap memory or just Heap. Whenever an

object is created using a new operator or by any other means, the object allocates memory from the Heap

and when the object dies or garbage is collected, memory goes back to the Heap.

A very simple explanation is that the Heap is the portion of memory where dynamically allocated memory

resides. Memory allocated from the Heap will remain allocated until it is freed or the program terminates.

This can be compared to the Stack memory which is where local variables (those defined within a method

or a function) live. More information about the Heap can be found in this article.

To adjust the amount of Heap use Research > JVM Settings or the IGMAS+ Settings App shortcut (see

Section 4.2.5.1 on page 32).

!
It is not recommended to use the full capacity of your computer’s memory but to preserve some

memory for the system.
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2.2 Installation

!
Before installation, make sure that Java Runtime Environment is installed (see Section 2.1.1.1 on

page 14).

For installing IGMAS+ you don’t need root- or administrative-permissions on your system-account.

Standard installer package contains a single installer Java Archive (JAR) file IGMAS-install.jar.

The JAR is a platform-independent file format that aggregates many files into one, for instance, multiple

Java applets and their requisite components (.class files, images and sounds). The JAR format supports
compression, which reduces the file size. In addition, individual entries in a JAR file can be digitally signed

to authenticate their origin.

2.2.1 Installation in Windows

Installation in desktop mode:

1. Browse to the folder that contains the installation package file IGMAS-install.jar

2. Execute the installer by double clicking on the file.

3. The installer starts, select language and follow the instructions of the installer.

Installation in command line mode:

1. Open command window (cmd) or PowerShell

2. Change directory to the one that contains the installation package file IGMAS-install.jar

3. Run command

> java -jar IGMAS-install.jar

4. The installer starts, select language and follow the instructions of the installer.

In order to create IGMAS+ desktop shortcut, check the appropriate checkbox (see Figure 2.1).

After installation is completed, IGMAS+ is ready for use with no need to restart the computer.

In order to update an existing version of IGMAS+ you can simply install the new version ’over’ the existing

one (use the same folder).
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Figure 2.1: Installation window: add shortcuts and menu entry

2.2.2 Installation in Linux

Installation in desktop mode:

1. Browse to the folder that contains the installation package file IGMAS-install.jar

2. Run the JAR file as a Java executable (don’t open it as a file archive, as this is often the double-click

default setting on .jar files). To do so, right-click on the installation package file and choose ”Open

with Oracle Java 6 Runtime” (the actual menu entry can vary).

3. The installer starts, select language and follow the instructions of the installer.

Installation in command line mode:

1. Open a Linux-shell (terminal)

2. Browse to the folder that contains the installation package file IGMAS-install.jar

3. Run the .jar-file as Java executable using the following command:

$ java -jar IGMAS-install.jar

4. The installer starts, select language and follow the instructions of the installer.
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2.2.3 Installation in Mac (t.b.a.)

To be added

2.2.4 Plugins

All plugins are included in the installer:

Borehole view Module Plugin for interactive visualization of borehole data.

Scripting Module Plugin for using the JSR 223 Standard of the Java Platform for script into the IGMAS

System with the Scripting Language of your choice.

StressLoad Module Plugin for calculation of the isostatic pressure in constant depth or on defined

interfaces.

Isosurface Module Isosurface extraction for Voxelcubes through marching cubes with surface

simplification

WorldWind Module NASA World Wind lets you zoom from satellite altitude into any place on Earth.

Leveraging Landsat satellite imagery and Shuttle Radar Topography Mission data, World Wind lets

you experience Earth terrain in visually rich 3D, just as if you were really there.

Segy Inspector Module SEG-Y Loader and Inspector.

Spherical Module The spherical plugin give you the possibility to transform your model into a geodetic

datum and calculate the effects there.

VoxelFFT Module Plugin for calculation of the Voxel Effect by means of the ”mass points in the wave number

domain (FFT)”-approach. Each vertical layer of the voxel cube is calculated separately applying field

continuation operator. The different components or gradient components are calculated in the wave

number domain, the effects are finally added in the spatial domain.

VoxelOpenCL Module Use the amazing potential of heterogeneous platforms consisting of CPUs, GPUs,

and other processors. OpenCL™ is the first open, royalty-free standard for cross-platform, parallel

programming of modern processors found in personal computers, servers and handheld embedded

devices.
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2.3 First Start

2.3.1 First Start in Windows

In order to start IGMAS+, user can use the IGMAS+ icon on the desktop.

The application shortcut can also be found in the Start Menu.

2.3.2 First Start in Linux

To launch IGMAS+ in Linux, navigate to your installation directory to

~/IGMAS/bin/script/

and run IGMAS+ by executing the IGMAS executable:

$ ./IGMAS

Prior to that, make sure you have executable-permissions on the file IGMAS by typing

$ ls -l

In the line of the script-file launcher.sh, an expression similar to the following should be displayed:

-rwx------

The ’x’ sign indicates executable rights and must be set for the user. If it is not set, executable-permissions

can be given without root-permissions by typing

$ chmod u+x ./IGMAS

The script contains the commands for launching IGMAS+ and may look like:

1 #!/bin/bash
2 cd "${BASH_SOURCE\%/*}/.."
3 java -cp igmas-process-wrapper.jar: igmas.process.StartIGMASProcess
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!

If you receive this error message

$ Error: Unable to initialize main class igmas.process.StartIGMASProcess
$ Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException

check your Java version by executing

$ java --version

or

$ java -version

It should output a version number starting with 1.8.

2.3.3 First Start in Mac (t.b.a.)

To be added

2.3.4 Theme Selection

On the first start you are asked to choose between the two available themes (light and dark). Have fun

choosing a design you love (Figure 2.2)

Once chosen, the theme will be saved and you won’t be asked again. However, the theme can be changed

in the menu entry Edit > Option > Look & Feel .

!
On Windows one can reset the theme selection by deleting the following registry value:

Computer\HKEY_CURRENT_USER\Software\JavaSoft\Prefs\igmas\gui\look.feel.dark

2.3.5 License Installation

When you run IGMAS+ for the first time or if your certificate has become invalid, you will need to install or

verify your license certificate for IGMAS+. If the License Wizard does not start automatically, please start

the wizard from the IGMAS+ menu Help > License Wizard .

Here you can choose to (re-)install, verify or uninstall a license certificate. When running IGMAS+ for the

first time, choose ’(Re-)Install a license certificate’ and click [Next].

On the next page, browse to the folder that contains your license certificate file (file extension is ’.lic’), mark

the file or type in its name and click [Open].

Afterwards, type in the serial number for your license certificate and click on [Install]. If you don’t feel

comfortable with your input being masked during typing, it can be optionally shown as clear text.

When the serial number for your license certificate has been approved, click [Finish] to exit the License

Wizard.
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Figure 2.2: Default theme selection in IGMAS+.

Once IGMAS+ accepted the license, it is not necessary to update the license after installing new versions.
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2.4 Uninstallation

Uninstalling IGMAS+ before installing a new version of the software is NOT required. Just install the new

version "over" the old one. The license status as well as all preferences will be kept. IGMAS+ should not

be running during the update/over-installation process.

2.4.1 Uninstallation in Windows

On Windows machines, you can find IGMAS+ app icon in the Start Menu, right click on it and choose

Uninstall.

Alternatively, run the file ~\IGMAS\Uninstaller\uninstaller.jar.

!

The IGMAS+ program preferences remain saved in the Windows registry. On a re-installation of

IGMAS+, the users preferences will be applied to the new installation. To delete the registry directory,

run regedit in the start menu and delete the folder
Computer\HKEY_CURRENT_USER\Software\JavaSoft\Prefs\igmas

2.4.2 Uninstallation in Linux (o.o.d)

On Linux (and comparable) systems, go to the IGMAS/Uninstaller folder and run

$ java -jar uninstaller.jar

or

$ I+uninstaller.sh

shell script in the ~/IGMAS/bin/script/ and follow the dialogue.

2.4.3 Uninstallation in Mac (t.b.a.)

To be added
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3CHAPTER

Getting Started

“ The secret of getting ahead is getting started.

”
Mark Twain

3.1 Foreword

This overview shall provide the basic working concept of IGMAS+ when used to investigate gravity fields,

including all aspects that need to be considered when starting an IGMAS+ project. The chapter is intended

to bridge general textbook knowledge on gravity modelling with the specific ”how-to” information given in the

IGMAS+ User Manual. Hence, it provides both key words from the gravity research field (without repeating

textbook contents) and definitions for IGMAS+ specific terms (to be further looked up in this manual).

3.2 Philosophy (t.b.e.)

Gravity anomalies - i.e. deviations from the normal field of gravity (Fig.1) - provide us insights into the

geological structure and related density distribution of a region. For a specific gravity anomaly, or more

realistically expressed, for an ensemble of anomalies to be explained, however, numerous density

heterogeneities are theoretically possible (Fig. 2). Note the ambiguity of all potential field observations! To

overcome this ambiguity by means of gravity-independent observations is essential to the modelling

philosophy of IGMAS+. With this software package, Free air, Bouguer- and geoid anomalies can be

modelled and calculated.

IGMAS+ allows users to calculate the gravity anomalies corresponding to a pre-defined 3D density model

and interactively compare the calculated/modelled fields to the observed anomalies. To interactively obtain

an optimised fit between calculated and observed anomalies, users can either (i) manually adjust a density

configuration by changes of density values and geometries of density bodies (Fig. 3) or (ii) automatically
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invert a gravity field for a density configuration. In this workflow, gravity independent observations (such

as geological maps, borehole information, seismic velocities and discontinuities, cross sections derived

from other geological and geophysical interpretations etc.) are integrated at two stages: (i) when defining

the density configuration of an initial 3D model and (ii) when interactively modifying the model while

simultaneously visualizing the independent constraints.

As common to all inverse approaches, the number of “free” parameters in the modelling process should

be significantly reduced before a final forward field matching, respectively inverse density calculation. For

example, the final modelling step may be limited to the adjustment of the thickness and lateral extent of a

model unit with pre-defined density (variation). Fixing as many as possible other parameters of the initial

3D density model thus requires input data of appropriate spatial coverage and (in the best case) well-known

uncertainties. On the other hand, the model should be kept simple, its complexity chosen just as to be able

to help answering a well-defined scientific question. Remember:

“ A model which images any detail of the reality is as useful as a map of scale one to one.

”
Joan V. Robinson
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4CHAPTER

User Interface

“ If you find an element of your interface requires instructions, then you need to redesign it..

”
Dan Rubin

4.1 General Layout

The general working layout is shown in Figure 4.1:

Figure 4.1: General IGMAS+ layout
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The main elements of the layout are:

Title Bar with Menu Entries (top) Most functions are called using either the menu entries in the Title Bar

at the top of the window or a right-click-menu entry or using the icons on the toolbar of each View.

Object Tree (top left) Contains all model objects. It is used to switch the visualization ”on” or ”off”

individually. Use right mouse button to get an object dependent menu for the individual elements.

The elements in the Object Tree are listed in a hierarchical order. Their properties are described in

the individual sections (see Section 4.3 on page 37).

Property Editor (bottom left panel tab) Is used to view or change the properties of individual elements

selected in the Object Tree.

Body Manager (bottom left panel tab) A table to view and modify the physical properties of all bodies

(see Section 5.3 on page 75).

Information (bottom left panel tab) Information on numerical data at cursor position and color scales.

Views Window (right tab) Contains one or more different views of the model (2D View, 3D View, 2D

Maps, Multiple Cutter, WorldWind, Help), which may be either changed using their tabs, or may be

detached and placed arbitrarily on the screen. Use right mouse click on Views Window tab, or ”drag and

drop” to arrange the views. If detached, the cursor tracking between the different views is provided.

Status (bottom window border) Click on [IGMAS+ started] to get a log of the current session. Refer

to Section 4.2.6.3 on page 34 to get more information on this session log. In the log window click on

Create Report to save the complete log.

Status information:

Memory status (left) Place the cursor above the status bar to get more information about actual

and maximum available memory. This information bar turns into red, if the allocated memory reaches

a critical level.

Refer to section 2.1.2.3, how to increase the available memory.

Progress bar (center) This bar visualizes the activity status. Please note, that the progress in not

necessarily linear.

Info-light (right)

= Model is inconsistent, triangulate and recalculate anomaly.

= Anomaly is inconsistent, use Re-calculate.

= Model and anomaly are consistent.
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4.2 Title Bar

In the title bar of the program window (Figure 4.2) one can find menu entries: File , Edit , View , Tools ,

Research , Help , as well as the IGMAS+ version number, the name of the loaded model and its timeline

version tag.

Figure 4.2: IGMAS+ window title bar.

The full version number can be found in the About window (Section 4.2.6.2 on page 34), it is also included

in the system report (Section 4.2.6.3 on page 34).

4.2.1 File

The typical file load/save functionality is implemented in Open Project and Save Project menu entries.

However, Import and Export entrees can be used for data exchange with other software products.

4.2.1.1 Project-related Menu Entries

• New Project is used to create a new project, see Section 5.2.1 on page 66

• Open Project is used to load an already created project, see Section 5.2.2 on page 67.

• Save Project and Save as are used to save the current modified project.

• Close Project is used to close the current modified project.

Both Save Project and Save as allow you to save the project within a folder. In both cases IGMAS+ will

ask after a directory name and a new directory (global folder) and subdirectory (timeline folder) will be

created. This directory structure keeps the valuable information about project changes over time. In this

way the user can always recover old and current models.

4.2.1.2 Import / Export Menu Entries

It is possible to import the following data to the IGMAS+ project:

• Borehole

• Model, see Section 5.2.3.1 on page 67

• Stations

• Interfaces
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• PointSet

• Image

• VoxelCube

• XML Project

4.2.1.3 Exit

Menu entry Exit is used to quit IGMAS+. Before closing, IGMAS+ will check for changes in the project

and a corresponding dialogue will pop up:

4.2.2 Edit (t.b.e.)

4.2.2.1 Sectioning (t.b.a.)

4.2.2.2 Model Triangulation (t.b.a.)

4.2.2.3 Preferences

Preferences window can be opened in the menu entry Edit > Preferences :
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Preferences are:
Name Function

2D

2D Rendering Quality High or Low (with or without antialiasing)

Isoline step size in % Percent of isolines between the max and min

Label every Contour number Show labels of isolines

Point Colour Colour of the polygons vertices

Size in Pixel (Point Size 2D) Size in pixels of the polygons vertices

show tooltip In 2D View ”on” or ”off” tooltip with polygons information
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Name Function

3D

Background Colour Select the Background Colour of the 3D View

Interface shading Switch between Gouraud or Flat Shading

Marker Colour Select the colour for the cursor tracking line

Marker Size Size in pixels of the cursor tracking marker

Marker Speed Update each Frame

Render Mode Select Render Mode between Solid, Wireframe or Point

Name Function

General

Clipping Box Colour Select colour for the model clipping box

Colour of the marker lines Select colour of the triangles lines

Colour of the Sections lines Select colour of the lines between polygons

Global transparency Transparency ”on”/”off” of bodies in the range [0-1] in 3-D View (see

Section 4.5.1 on page 50)

Marker Line Width Select width of the triangles lines

Project Path Define Path for the current user

Section Line Width Select width of the lines between polygons

Show clipping Bounds Show model clipping box ”on” or ”off”

Show marker Lines Show triangles lines ”on” or ”off”

Show Polygon Outline Show lines between polygons ”on” or ”off”

use Antialiasing Antialiasing ”on” or ”off”

4.2.2.4 Options: Look & Feel

To change the Look & Feel of IGMAS+ go to Edit > Options > Look & Feel and select one of the three

possibilities:

1. FlatLaf Dark: dark theme

2. FlatLaf Light: light theme

3. Metal: legacy metal theme

The two first themes are based on Flat Look and Feel (FlatLaf) Java Swing desktop application.

4.2.2.5 Options: Language

IGMAS+, IGMAS+ installer and IGMAS+ Settings are available in two languages:

• English (default)

• Deutsch (German).
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4.2.3 View (t.b.a.)

4.2.4 Tools (t.b.a.)

4.2.5 Research (t.b.e.)

4.2.5.1 JVM Settings

In Research > JVM Settings user can adjust the following settings related to the JVM (see Section 2.1.1.1

on page 14):

Initial heap size When JVM starts, its heap space is equal to the initial size of heap memory specified by

this parameter. As application progress, more objects get created and heap space is expanded to

accommodate new objects. Usually it is not needed to adjust this value.

Maximum heap size The JVM expands heap memory in Java somewhere near to maximum heap size

specified by this parameter and if there is no more memory left for creating new objects in java heap,

JVM throws java.lang.OutOfMemoryError and application dies. Adjust it if you have problems
with loading or creating a big model (see Section 6.5 on page 144).

JRE for IGMAS+ Version of the JRE used by IGMAS+. See Section 2.1.1.1 on page 14.

Proxy settings Setup proxy settings for internet connection, if needed.

Stereo Settings User can force stereo rendering which can help to remove potential visualisation bugs (see

Section 6.5 on page 144).

User can also set the settings to default (Default) or use optimized settings (Optimized).

The JVM settings window can also be accessed directly from the system without starting IGMAS+. In

Windows 10 just type IGMAS+ settings in the Start Menu to find the shortcut:
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! You should restart IGMAS+ for changes in JVM settings to take effect.

4.2.6 Help (t.b.e.)

4.2.6.1 Help Window (t.b.e.)

The menu entry Help > Help will show a window with basic help:

1. List of shortcuts (see also Section 4.6 on page 59)

2. Basic references (for the full reference list see Section 6.5 on page 148)

3. Description of equation symbols and functions.
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4.2.6.2 About Window

The menu entry Help > About will show a window with all relevant information about IGMAS+ (Figure 4.3)

including the build date, license status, JRE (see Section 2.1.1.1 on page 14)

Figure 4.3: IGMAS+ window About with relevant software information.

4.2.6.3 Log Window and System Report

Time-stamp information about libraries and plugins loaded, java exceptions and functions performed during

the current session, is logged automatically and may be viewed: Click on [IGMAS+ started] in the status

bar at the bottom of the main IGMAS+ window to display the log window:
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The content of this window is written automatically into an ASCII log-file named igmas_log_0.log in
the installation directory ~/IGMAS+/bin. This file is created each time the program is started, concurrent

program starts will result in increasing of log file numbers (igmas_log_1.log, igmas_log_2.log,...).
Existing files are overwritten without notice.

A system report file (XML format) may be created by clicking on the Create Report button at the bottom

of the log window.

If you want to report an error, please send both files to igmas-support@gfz-potsdam.de.

4.2.6.4 License Wizard

In the License Wizard it is possible to:

1. Install or reinstall a license certificate

2. Verify current license certificate

3. Uninstall current license certificate
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4.2.7 Toolbar (t.b.e.)

In the main IGMAS+ toolbar there are following icons:

Symbol Function

Calculate anomalies

Recalculate anomalies

Model triangulation

Linear parameter inversion

Voxelize Model

Clip to model

Clip to stations

Switch to 2D Maps

Scripting Module

Undo-functionality

Redo-functionality

Stress map

World Wind Module/Global View
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4.3 Object Tree (t.b.a.)

The Object Tree is used to control and set up visualization of the project, as well as for navigation in the

project workspace and settings.

Chapter 4 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 37



4.4 Model Elements

4.4.1 Body

The basic model element is the body, which defines an area of constant density / susceptibility. Its hull is

composed of a number of triangles with controlled orientation. This hull has to be complete, without gaps or

overlapping triangles. For an isolated body its surrounding is the ’Reference’, but usually it has more than

one direct neighbours.

Each body has a number of properties, which may be visualized or changed using the Property Editor.

4.4.2 Interface

An interface is a set of triangles separating two bodies. Each interface belongs to one body on the right hand

side and to another body on the left hand side (left and right is defined by the mathematical orientation

of the triangle, not by the geometry itself, see Section 6.1.6.1 on page 126).

All existing interfaces are listed in the Project Tree, their visualization in the 3-D View may be switched

on or off using the checkboxes (see figure below).

The Project Tree shows two body names for each single interface, which are separated by the body separator

<>. The first name specifies the name of the left body, the second name the body on the right hand side:
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The entries of the list are sorted according to bodies: each body has an entry in the first hierarchical level,

followed by all interfaces surrounding this body, i.e. building its complete hull.

The interfaces themselves as well as their list are built automatically and cannot be changed by the user.

Interfaces do not have user manipulatable properties.

The following figure shows all interfaces which belong to the hull of body ”Caprock”:

• Caprock and Cretaceous

• Caprock and Zechstein

• Reference and Caprock

Together they build the complete hull of the body ”Caprock”.

Interfaces are the target for the anomaly calculation: there is no anomaly without at least one interface

separating two bodies with different physical parameter (see Section 5.5 on page 95).

4.4.3 Section

Sections are vertical planes, which are used as carriers for the geometry vertices. Each vertex of a

triangle lies on one of the sections, the vertices of each triangle have to lie either on adjacent sections, or
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on the same section (in this case they are vertical). There are no vertices between the sections.

All sections of the model have to be parallel to each other, however, they do not have to be equidistant nor

do they have to be parallel to the axes.

Name User can set up a specific name for the section (by default name is the index).

Section Normal The normal defines the orientation of the section, it is not changeable, as it has to be

defined during the model initialization process.

Point Two points define the position of each section (not changeable for an existing model).

Section Mirror Each section may be accompanied by one or two mirror sections, which may be used to

control the 3-D triangulation. Please refer to Section 5.4.5.2 on page 88 for a detailed discussion on

the role of the section mirrors.

You may Remove or Copy and Shift an existing section (right mouse click in the Project Tree). Use

Edit > Model - Triangulation or select the icon after these functions.
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The 2-D View (Add View→ Add 2D View) is used to display the geometry on the sections. Step from one

section to the adjacent one using the Up/Down-arrows in the Toolbox .

! The geometry of the model can only be changed in the 2-D View.

4.4.4 Polygons and Vertices

The 2-D Views of the sections (see Section 4.4.3 on page 39) show the model along the section which build

polygons. The polygons are defined by a number of vertices, usually marked with grey circles. Vertices

marked with red colour relate to triangulation errors (see Section 5.4.5 on page 85).

!
The geometry of the bodies is changed implicitly (automatically) by modifying the geometry of the

polygons on the sections.

The vertex symbols (default: grey circles) may be switched on and off (use key v ). Their size and color
may be changed in Edit > Preferences .
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Polygons are always related to a section. Their properties are:

Body Part Index A name or index, which may be assigned to each polygon. This name is used to identify

geometrically separated parts of the same body. Used for the triangulation (see Section 5.4.5.3 on

page 90).

zState Position of a polygon relative to the other polygons of the same body. The zState is for information

only, it is set by the program.

Possible values of zState property are:

Body The interior of the polygon defines the intersection of a body with the vertical section. The body is not

changed here, but may be changed using the function Set Body(s) (see Section 5.4.4.2 on page 83).

The vertices define the geometry of the polygon. They may be shifted, deleted or inserted (see

Section 5.4.1 on page 80). A polygon may be removed using right mouse menu on a polygon in the

Project Tree (remove).
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4.4.5 Stations

The observed , calculated or residual gravity or magnetic fields are defined at stations i.e. a set

of points with arbitrary position (x, y, z). If the elevation (z) is not given, 0 is assumed.

An offset (default: 13 cm) may be added to each station elevation. IGMAS+ assumes the coordinate system

of model and station data to be identical.

The station positions are displayed as red points in the 3-D View and as a red profile line in the 2-D View.

The station coordinates are usually imported together with the measured field(s) from an ASCII file (.csv
or .stations, see Section 6.3.4 on page 136). This function is deactivated, if there is no model present.

Please refer to Section 5.5 on page 95 for a detailed discussion on station elevation.

Stations have two important changeable properties:

zOffset This offset will be added to every station elevation. It may be used to shift all the station elevations

by the same amount. The default of 13 cm simulates the distance of gravity meter systems from the

ground.

The zOffset is saved in the project file (Section 5.2.1 on page 66).

Projection distance This value is used as the maximum distance of station locations to be projected on the

2-D Views. The projected measured stations are marked with the symbol +, the calculated stations

with a circle. The default (0) results in no projected station symbols at all.

The projection distance is saved in the project file (Section 5.2.1 on page 66).
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4.4.6 Anomaly Fields

The anomaly fields are given at each station as point data (ref section 4.4.5). For the 3-D View the station

points are triangulated and build a coloured surface, for the 2-D View the station triangulation is cut with

the section line and displayed as profile line above each section display.

! Click on the legend entry to change the line style of the field profile lines.

The following fields are available (each measured or/and calculated):

Gravity The three components (Gx, Gy, Gz). Gz are usually called ’gravity field’.

Gravity gradients All tensor components (Gxx, Gxy, Gxz, Gyx, Gyz, Gzz). Horizontal Gradient HGz

and Horizontal directive tendencyHDT which are based on the calculations of the Gradient Invariants

Inv0, Inv1, Inv2.

Magnetic The three components (Mx, My, Mz) and the values (MAGtot, V G, MAGtotr) where

(MAGtot) is the total magnetic field anomaly, (V G) is the vertical gradient calculated between the

position of your station and 1 meter upwards and (MAGtotr) is the total sum of induced and remanent

field anomalies.

Each field has its individual properties:
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Auto Scale Only affects the 3-D View: The scale of the 3D anomaly field(s) in comparison to the vertical

model extension. If switched on, both are identical.

Auto Shift The constant offset between measured and corresponding calculated anomaly field is subtracted

automatically, if switched on, as follows:

shift = mean(measured)−mean(calculated)

calculated = calculated+ shift

This correction is updated after each modification of the calculated anomaly.

Shift value Only used, if Auto Shift is switched off: the value is used to be added to the calculated

anomalies, which causes a constant offset.

Scale Z Only used, if Auto Scale is switched off. The value is used as a factor to be multiplied with the

corresponding anomaly.

error Estimated error of the anomaly fields. Used for the inversion of the physical parameter(s)

(Section 5.3.1 on page 76).

!
error gz indicates the estimated error of the component Gz. error gxx is the estimated error

of the component Gxx, etc.

Values Statistics concerning the difference between measured and corresponding calculated field:

• Average difference between measured and calculated anomaly (= shift, see above)

• Correlation coefficient

• Standard deviation

• Variance

These values are only for information, and only available if both measured and calculated fields are

defined. They are updated after each modification of the calculated anomaly.
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Each field can be visualized in the both 2-D and 3-D Views.

In the 3-D View you can switch between individual anomaly visualization, select shading ”on” or ”off” and

control the transparency of the anomaly representation.

4.4.7 Model

The ’model’ comprises all information about model (geometry and physical parameters) itself and the

stations including their position and field data (see figure).

The model properties are a name, the inducing Total Magnetic Field (magnitude, inclination and declination),

and the vertical exaggeration to be used in 2-D and 3-D Views (default: 1).
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4.4.8 Clipplanes and Bounding Box

Usually gravity models are extended laterally in order to avoid edge effects (more details in Section 5.10 on

page 121).

As these extensions are cumbersome for 3D visualization, they are clipped automatically in 3-D Views, using:

• the lateral bounding box spanned by the station positions

• the maximum vertical extension of the model and the station elevation
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The clipplanes display the cuts of the clipping-box with the model. They are six planes, one for each

side.

Their position may be changed using the slider (select the appropriate entry in the Object Tree, then use

the corresponding Property Editor tab). To reset the position of the six clipplanes, use the Property Editor

of the ”Clipplanes” entry in the Object Tree.

Clip to Model: Sets the clipplanes to the extremes of the model, without regarding the station positions.

Use Clip to Model as well by clicking on the icon .

Clip to Stations: Sets the clipplanes laterally to the station area, and vertically to the model area. Use Clip

to Stations as well by clicking on the icon .

The following figures show the same model as previously, but clipped to the station covered area. Without

(left) and with (right) clipplane visualization:
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!
The clipplane reset function has to be used, if the bounding box is to small (e.g. after geometry

modifications).
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4.5 Views Window

In the Views Window user can open tabs with different views:

• 3D View

• 2D View

• 2D Maps View

• Multiple Cutter View

• WorldWind View

• Scripting View

Each View has its own toolbar to facilitate navigation and use the interactive interface to its full potential.

4.5.1 3-D View

The 3-D View is the default view, but you may want to have more than one 3-D View panel opened in

your workspace. Use View > Add View > Add 3D View to add more panels. Use the [Tab] to toggle

between views or detach them and place them on your monitor(s). To attach them again, click the symbol

at the upper right corner of the View:

Use the checkboxes of the Object Tree to activate or deactivate the visualisation of the project elements

individually.

! The 3-D View does not provide editing functions.

4.5.1.1 Functions

Zoom in and out: mouse wheel or [Alt]+ left mouse button

Translation: right mouse button

Rotate: left mouse button

Fit into window: For optimal view press f

Center at Top|Bottom|Left|Right|Front|Back: Use View > Center at to get one of the 6 default

views.

Transparency: Toggle the transparency of an entire body on|off by clicking

[Ctrl]+left mouse button on the body. This affects all interfaces and all polygons of the

corresponding body. Change the global transparency with Edit > Preferences to set the intensity

of the transparency effect (from 0 to 1, default is 0.5).
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4.5.1.2 Head Up Mode

The rotation in 3-D is restricted so that the direction of the z-axis does not change. This is so-called Head

Up Mode which is activated by default. Deactivate it if you want to have unlimited rotation freedom.

! Use Edit > Preferences > Controls (Section 4.2.2.3 on page 29) to reverse the moving effects or

to change the Head Up Mode.

4.5.1.3 Right-Mouse-Button Menu

Add Bookmark
Show Object In Table

Show Object In Tree

Centre Object(s)

Render
Render Solid (default)

Render Wireframe
Transparency (on/off)

View
Perspective View (default)

Parallel View
Stereo
Edit Stereo Settings

Center at
View Left
View Front
View Bottom
View Right

View Back
View Top

Export View as ...

Add bookmark Use this function to save the coordinates of the actual 3-D View. A new entry in the Object

Tree appears: . The bookmark(s) will be saved in the project file together with other project data

(Section 5.2.1 on page 66).
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Show Object In Table Use this function to show the selected body in the Body Manager (Section 4.1 on

page 26).

Show Object In Tree Use this function to show the selected body in the Object Tree (Section 4.3 on

page 37).

Centre Object(s) Fit the 3D model to the screen.

Render Use this function to render the bodies with different visible features: Solid, Wireframe and with

or without Transparency. Solid renders images with surfaces. Wireframe renders images without

surfaces or textures, showing the triangulated interfaces. Toggle the transparency of an entire body

(on|off) using the function Transparency.

Center at Use this function to get one of the 6 default views: Left, Front, Bottom, Right, Back or Top.

4.5.2 2-D View

Use View > Add View > Add 2D View or [Ctrl]+ a to add a 2-D View to the default 3-D visualization.

Use the [Tab] to toggle between views or detach them. To attach them again, click the symbol at the

upper right corner of the View:

Use the checkboxes of the Fields entries (in the Object Tree) to activate or deactivate the visualization of

the anomaly field(s) individually. The checkboxes of the other elements only affect the 3-D View.

The 2-D View is used for visualization and for editing (Section 5.4 on page 80). It shows in the lower part

one of the sections of the model, with the section name at the bottom (right).

Above the section geometry the corresponding (active) anomaly profile line(s) are shown. The anomaly

scale is set globally, so that it is not changed for different sections. Click on to switch to local scaling

(each sections individually). Click on to switch back to global scaling again.
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4.5.2.1 Functions

Zoom in and out: mouse wheel or [Alt]+ left mouse button , or

z + diagonal selection with left mouse button

Translation: right mouse button

Fit into window: for optimal view press f or in the Toolbox.

Next|Previous section: press PgUp / PgDown or the arrows in the Toolbox .
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View Front|Back side of the section: press (Frontside) or (Backside). No effect if both sides are

identical (more details in Section 5.4.5 on page 85). The information, whether a polygon lies on the

front or the back side of the section, is shown as polygon property (zState, see Section 4.4.4 on

page 41).

Tooltips: In the 2-D View mode the tooltip gives information about the model (polygon name, polygon area,

body part index and physical properties) where the cursor is currently located (may be deactivated in

Edit > Preferences ).

4.5.2.2 Right-Mouse-Button Menu

Show Object In Table

Show Object In Tree

Set Body Part Index

Set Body(s)

Divide Body

Control
Show Points (on|off)

Centre
Next
Previous
Show Section Back
Show Section Front (default)

Alpha numeric

Activate Body

Clear Selections
Combine Polygon(s)

Export View as ...

The functions Show Object in Table and Show Object in Tree are described in the Section 4.5.1.3 on

page 51.

The editing functions Set Body Part Index, Set Body(s), Divide Body, Activate Body, Clear Selections

and Combine Polygon(s) are described in the Section 5.4 on page 80.

Other functions:

Control Show vertices: press v to toggle between on and off. Centre: Fit into window by pressing f .
Next|Previous section and View Front|Back side of the section.
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You can also use the icons on the 2-D View toolbar.

Alpha numeric Function to view/change vertex coordinates. Select one or several vertices, then click on

one selected vertex with the right mouse button:

If only one vertex is selected: Enter the absolute x and z coordinate of the vertex.

If multiple vertices are selected: Enter relative distances (x and z), which will be added to all

selected vertex coordinates.

4.5.3 Multiple Cutter View

In IGMAS+ all vertical sections of the model have to be parallel to each other. In many cases the user needs

to visualize the 2D model and anomalies from different perspectives. The Multiple Cutter allows to cut the

model and the anomalies in arbitrarily oriented 2-D sections.

Put the mouse in the map on the left, above and select a start point. After selecting the start point, the mouse

move refreshes live the cut, and click finalizes it. Different model and anomaly cuts can simultaneously be

visualized in 2D.

!
The Multiple Cutter is exclusively a visualization tool, it does not build polygons out of the cross

sections. Please do not mismatch it with ”Sectioning”.
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4.5.4 2D Maps View (t.b.a.)

4.5.5 WorldWind View (t.b.e.)

Click on to get a new tab for global 3D visualisation of anomalies and model. Select items to be visualized

in the Project Tree. Use small icons in the upper right window bar to show / hide items like scale etc.

To display the WMS (Web Mapping Service) layer manager click on or click right mouse button on

the entryWorldWind Manager→ ShowWMS Manager. To add a WMS service, select the + (see figure),

and enter the URL into the next window.

Here you find the URL’s of interesting web mapping services concerning geology: One Geology (http:
//portal.onegeology.org/). Search for your area of interest, click on Active Layer Properties and
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then look for the Service URL, copy and paste it into the IGMAS+ URL Window.

Examples for some WMS (please consider ev. license conditions):

Geology global:

http://mapdmzrec.brgm.fr/cgi-bin/mapserv54?map=/carto/ogg/mapFiles/CGMW_Bedrock_and_Structural_Geology.map&

Geology Europe:

http://mapdmzrec.brgm.fr/cgi-bin/mapserv?map=/carto/ogg/mapFiles/GISEurope_Bedrock_and_Structural_Geology.map&

Geology Europe:

http://www.bgr.de/Service/OneGeology/BGR_Geological_Units_IGME5000/?

Geology Germany (1:1 Mio, BGR):

http://www.bgr.de/Service/OneGeology/BGR_EN_Geological_Units/?

Geology Austria:

http://gisgba.geologie.ac.at/ArcGIS/services/OneGeologyGBA/MapServer/WMSServer

OpenStreetMap global:

https://www.terrestris.de/en/openstreetmap-wms/

!
WorldWind vizualisation requires:

• an active internet connection

• a global coordinate system (geographical projection, see Section 6.2 on page 128).
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.

4.5.6 Scripting View (t.b.e.)

The Scripting View is used to edit and evaluate the user scripts. Read more in Section ?? on page ??.
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4.6 List of Shortcuts

4.6.1 General Shortcuts

List of general shortcuts:

General Shortcut Function

[Ctrl] + a add 2-D View

[Ctrl] + c close Model

[Ctrl] + o open Model

[Ctrl] + s save Model

[Esc] cancel

f fit to screen

4.6.2 2-D View Shortcuts

List of Shortcuts available in 2-D View:

2-D View Shortcut Function

s + [define region with left mouse button] select a group of vertices. May be used more than once.

i + [left mouse button] Insert / delete vertex

[PgDown] previous section

[PgUp] next section

[right mouse button] + [move mouse] shift section

z + [left mouse button] + [move mouse] zoom into region

[Alt] + [left mouse button] + [move mouse] zoom in and out

[Shift] + [left mouse button] + [move mouse] shift vertex / marked vertices

d + [left mouse button] + [move mouse] divide polygon between vertices (uncheck ’Automatic

Update’)

x + [left mouse button] select polygon (un-check ’Automatic Update’)

v toggle vertex display (on|off)

4.6.3 3-D View Shortcuts

List of Shortcuts available in 3D View:

3-D View Shortcut Function

[Alt] + [left mouse button] + [move mouse] zoom in and out

[Ctrl] + [left mouse button] toggle body transparency

[right mouse button] + [move mouse] shift model
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5CHAPTER

Workflows

“ Design isn’t finished until somebody is using it.

”
Brenda Laurel

5.1 Creating a Simple Model

This function is available only if there is currently no model loaded.

5.1.1 Creating a Project

New Project is the function to create a new project. There are two possible ways of creating a project:

1. New Model: build a new model from scratch

2. Horizon Import: import single horizons (see Section 5.2.3.3 on page 69)
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5.1.1.1 New Model

Choose File > New Project > New Model . The New Model Settings wizard will open:

Coordinates Set the origin (X, Y), the size (Width, Height) and the depth (Depth). Don’t forget to choose

the units (m / km). Default is X,Y = 0,0; Width, Height = 10,10 and Depth = -5. Change the values

according to your needs and click on Next .

The following window will open:

Chapter 5 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 61



The window shows a map of the model area to be created. Change the values according to your needs:

Number of sections Click on - (to decrease) or + (to increase) and on dist to set the distance between

sections.

Location of the first section Either move the green circle, or click the green circle with right mouse button

to use alphanumeric input.

Location of the last section Either move the red circle, or click the red circle with right mouse button to

use alphanumeric input.

Direction of sections The default direction of the model sections is parallel to the x-axis. Click on the

arrow and change the direction according to your needs. For example if magnetic measurements were

obtained over profiles which are not parallel to the x-axis, you can define the azimuth of your sections

by changing the arrow position. If you don’t like to use the azimuth orientation, for the calculation of

magnetic anomalies is necessary to transform the magnetic declination (parameter declination, see

Section 4.4.7 on page 46) into a declination for calculations for IGMAS+ (Section 5.4.6 on page 92).

After finishing the input, choose Finish . A cube will be created automatically. Using the default values,

you will get the following model:
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Click on Edit > Model – Triangulation to build the triangulation between the sections.

Go to the Body Manager . The list of bodies now contains the two items:

• new_body

• reference

Choose Add Parameter > Density and set the two densities.

5.1.2 Creating Stations

Choose Tools > Create Station – Grid . Enter the area of the stations: the origin of the grid (X, Y), the

size of the station grid (Width, Height) and the cell size (X-Step, Y-Step). The stations are displayed as red

dots, the station area is reddish.
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Choose to calculate the gravity (Gz) of the model: Tools > Calculate Anomalies will display a wizard to

select one or several fields to be calculated. The result will be displayed as a coloured surface above the

model:

Now add a 2-D View ( Add View > Add 2D View ) in order to display the geometry on one of the sections.
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5.2 Input and Output (o.o.d.)

The typical load / save functionality is implemented by Open Project and Save Project menu entries.

However, several additional import and export functions may be used for data exchange with other software

products.

5.2.1 New Project / Save Project

Use New Project to create a new project. After creating a new project, both Save Project and Save as

allow you to save the project within a folder. In both cases IGMAS+ will ask after a directory name and

a new directory (global folder) and subdirectory (timeline folder) will be created. This directory structure

keeps the valuable information about project changes over time. In this way the user can always recover

old and current models.

Accroding to the timeline base project management concept is introduced in IGMAS+ (see Section 1.3.3 on

page 11), project data are saved in a special directory structure, the IGMAS+ file dialog will identify these

folders and mark with an icon . The file dialog shows the timeline state of the project:

The following data are saved in the timeline folder inside the global project folder:

• station coordinates, the calculated (voxel and triangle) response for every body in the model and the

measured data in each station

• indices for the Delaunay triangulation of the stations

• indices and coordinates for the model geometry

• section and polygon definition

• interface and triangles definition

• voxel cube definition with all voxel values and current voxelization with the model geometry

• body definitions with properties (unit in projection tag will be ignored)
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• user defined groups of interfaces (Stress Reference etc.), bookmarks definition, image definition,

vertex set definition

• units for acceleration, angle, gradient gravity, magnetic flux density, magnetization

• volumetric density

• state of calculated fields

• z-offset of the station grid, state of voxel algorithm, voxel state (name, use anomaly, minimize)

• some metadata of the project state.

The following data are saved in the global project folder:

• additional data/images will be all imported images (global context)

• additional data/vertex sets will be all points sets saved binary in the project

• save layer state from the WorldWind (opacity, visible, sorting, web map services, view)

• project name.

5.2.2 Open Project

Use Open Project to load an already created project. The file dialog shows the list of all (under this project

name) saved project versions, including the metadata. The user loads one version of the project.

In this use case the menu option Save Project will create a new timeline folder (time stamped) and all

model changes will be saved in this new folder.

If the user chooses the Save as menu option a new directory (global folder) with a new name and a new

subdirectory (timeline folder) will be created.

5.2.3 Import / Export

5.2.3.1 Export / Import Model

The only file format for saving model data is XML file with the file extension .model or .xml. The file

contains all necessary information as

List of all bodies: name, color, physical parameters, voxel equations and voxel factors

List of all sections: name, position, vertices, polygons

List all Interfaces: triangles

Compatibility with the Linux IGMAS+ version:

The Linux program (meta2xml) converts old .meta files into the new IGMAS+ format.

The XML model file is an ASCII file with clear human-readable text metadata and descriptions, so it is possible

to examine the file.
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!
It is possible change the XML model data file manually in the text editor, however user should be careful

and make backups to avoid the situation when the model file could not be read.

For loading a model, the file format .model, .xml (see above) as well as the GOCAD® TSurf (.ts) file

format (Section 6.3.6 on page 138) are accepted.

After having loaded a model, the triangulation is calculated automatically, except if the Automatic Update

is deactivated.

After triangulation of the model or after loading an external triangulation, the validity of the triangulation is

automatically checked for:

Completeness: Each body has to be surrounded by a complete hull of triangles.

Orientation: The hull of triangles has to take the orientation of the triangles into account.

Usually IGMAS+ will take care of a correct triangulation, you don’t have to worry about it. If a triangulation

is imported, however, or after a triangulation error (see Section 5.4.5 on page 85), it is necessary to check

it.

The result of the triangulation check is shown in the window (refer to Section 5.4.5 on page 85 for further

details).

5.2.3.2 Import Project (XML)

!

This function only exists to transfer ”old” IGMAS+ projects (saved as .igmas file) into the newer
version (starting June 2014).

Newer versions: please refer to description of Open Project and Save Project menu entries

(Section 5.2.2 on page 67).

The project file contains:

• The file name of the model data

• The file name of the station data

• The file name of the imported image(s)

– Name

– Coordinates

– Section name to map the image in 2D

• The file name of the imported pointset(s)
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– Columns of the .csv file, if no header is used
– Colors and symbol types

– Projection distance

• Saved Bookmarks (Section 4.5.1.3 on page 51)

5.2.3.3 Import Horizons

This function may be used if existing digital data define continuous horizons in the entire modelling area.

Several horizons are stacked, the physical parameters between the interfaces are assumed to be constant.

Users must use one file for each horizon.

File formats The following formats are possible: .xyz, .csv or Geosoft binary grid format .grd, see
Section 6.3 on page 132.

Point types The points defining the horizons may be gridded or irregularly distributed. Points with identical

location but different z-values will be averaged (there will be a notice).

!
The points are interpreted to represent point locations x, y, z. They are not to be confused with grid

cells, which are not used here, even in case of regularly gridded horizons.

How to import:

1. Choose File > New Project > Irregular/Regular Horizon (XY-Plane) Import . Choose the

directory and the file(s) to be imported. Make sure to select all files for the model to be built, as

later inclusion of additional horizons is not possible.

2. The import wizard lists all imported horizons (files) and orders them from top to bottom according

to the value Zmax. The order (from top to bottom) is very important, because it directly controls

the triangulation. Make sure, that the list corresponds to the stratigraphic column / layering in your

modeling area. If necessary, change the order using the arrows on the right hand of the wizard.
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Name This name will be used as the name of the body below the corresponding horizon. Can be

changed later.

# of points Number of points to be read from file (for information only).

Area Minimum x-coordinate, minimum y-coordinate, size in x-direction, size in y-direction (for

information only).

Zmin Minimum depth of the horizon (for information only, the value is used to define the layer order.

Zmax Maximum depth of the horizon (for information only).

# of x-points, # of y-points This value is used to apply averaging of horizon vertices on regularly

spaced locations. Default is 0 for irregular points and original number of points for grids (no

averaging). All three coordinates (X, Y and Z) will be averaged using the block average method

(see Section 6.1.4 on page 124). Alternatively, user can use x-spacing and y-spacing to set

up the grid for averaging (see below).

x-spacing, y-spacing Instead of setting number of points one can set desired spacing and

corresponding number of points will be automatically recalculated.

! The last four columns can be used for filtering of highly oversampled horizons.

3. The next wizard defines the general model parameters:

Extend model borders Check, if the model should be extended laterally, and specify the model

extension (Range). Refer to Section 5.10 on page 121 in order to read more about the model

extension.

Minimum vertical distance Minimum thickness of bodies. It is used only if the imported vertices

have identical horizontal positions throughout all horizons or if the vertices are interpolated

regularly on the sections (see Project Points (Mundry) below).
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Z-Top Depth of the upper limit of the model (plane, horizontal). Default 0, if no topography is given,

otherwise maximum Zmax of all horizons.

Z-Bottom Depth of the lower limit of the model (plane, horizontal). Default: minimum Zmin value

of all horizons.

Project Points (Mundry) Interpolate irregularly spaced horizon vertices on the sections to be build.

Default: no.

4. Select Next to continue. The last step defining the model specifies the area to be modelled and the

position of the vertical sections:

By default the modeling area is the maximum area, which is covered by all horizons - indicated by a

grey rectangle.

Green circle Defines the south-west corner of the modeling area.

Red circle Defines the north-east corner of the modeling area. You may change the position of the

circles by either clicking with right mouse button on them (alphanumeric input), or just

dragging them.

Number / distance of vertical sections The vertical sections to be created are indicated by dashed

lines. Click on + (increase) or - (decrease) to change their number. Alternatively quantify their

distance by clicking on dist.

Direction of the vertical sections Click on the arrow and move the mouse to change the direction.

Default: West-East.

!
The direction of the sections should be as close as possible perpendicular to the dominating strike

direction of the structures to be modelled.
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5.2.4 Bitmaps for Constraining Data

Use bitmaps to visualize additional information or constraints like depth converted seismic sections or time

slices, geological maps, or other geoscientific information. The following figure shows a semi-transparent

seismic image in a 3-D View.

To import an image, choose File → Import → Import Image. You get the following wizard:

Bitmap Location: Browse for the bitmap file (for on overview of formats see Section 6.3 on page 132).

Name: Type in a name for the bitmap. This name will be used in the model tree. Default is the filename.

Map to Section [2D mode]: Select a section from the drop-down-list in order to link the image to this

section in the 2D view. In the 2D views the bitmap will be projected onto the 2-D sections, and it will be
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shown only on the section where it is mapped to. If you uncheck this option, the bitmap is displayed in 3-D

views, but not in 2-D views.

Top left | Top right | Bottom left | Bottom right: Coordinates (x, y and z) of the corresponding 4 edges

of the bitmap. The coordinate system has to be identical to the coordinate system of the model.

Object tree: The bitmap(s) get an entry in the object tree: . Check to display it, use right

mouse click to remove the bitmap.

Property editor: Through the property editor of the bitmap you may either retrieve the import wizard

again to modify coordinates or 2-D mapping or change the transparency of the image: 0 (no transparency)

through 1 (full transparency).

.

The imported bitmap(s) including their settings are saved in the project file (Section 5.2.1 on page 66).

5.2.5 PointSets for Constraining Data

Additional meta data like Euler depth solutions or well log positions can be imported using .csv (see

Section 6.3.1 on page 132) or .xyz files (see Section 6.3.2 on page 134).

Select File → Import → Import PointSet, load the pointset file.

Object tree The pointset(s) get an entry in the object tree: , where it is called Metadata.

Check to display it, use right mouse click to remove the pointset.

Property editor Through the property editor of the pointset you may modify properties:
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Color Change the default green color.

Name This name will be used in the model tree. Default is the filename.

Point size Symbol size, when displayed in 2-D/3-D View.

Projection distance Points within this horizontal distance from a section are projected onto the current

section, displayed in the 2-D View.

Property editor:

Color:

Name:

Point size:

Projection distance:

The imported pointset(s) including their settings are saved in the project structure (Section 5.2.1 on

page 66).

5.2.6 Export Interfaces

The export of interfaces (TIN, i.e. triangulation and corresponding vertices) is still not implemented. Actually,

IGMAS+ exports only the vertices, which belong to a certain interface.

Select the interface(s) to be exported in the Object Tree and unselect all the interfaces which you don’t

want to be exported. In the 3-D View only the interfaces to be exported are visible.

Select File > Save > Export Checked Interfaces .

The vertices will be saved in .csv format (Section 6.3.1 on page 132). The vertex positions (X, Y, Z) of all
selected interfaces are saved into one file, separated by header lines, indicating the body names on either

side of the interface:

#Cretaceous Jurassic
500000.0 -500000.0 -2479.0
18011.0 0.0 -2547.0
500000.0 0.0 -2479.0
500000.0 -500000.0 -2479.0
17579.0 -500000.0 -2390.0
18011.0 0.0 -2547.0
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5.3 Modification of Physical Properties

The triangulated interfaces, which are used to define the density structures, are used to separate areas of

constant densities or susceptibilities. These areas are called bodies. Isolated bodies are surrounded totally

by a special body called reference body. Several bodies may touch each other (they share a common

interface) and in addition, they are all surrounded by the reference body:

The reference body is not shown in 2D as it does not build a closed body. Instead, the reference is assumed

everywhere, where no model polygon exists ( white background colour as on the figure above).

The reference body has a physical parameter, the reference density, which may be changed.

Please refer to Section 5.10 on page 121 for a more detailed discussion on the reference density.

The Body Manager (a tab in the lower left part of the IGMAS+ window) offers a simple overview and an

easy handling of the physical property of each body.

The table lists all physical parameters available for all bodies defined for the model. Modify the names and/or

the values.
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!
The body with the name Reference cannot be renamed - this body has a key function, as it defines

the surrounding of the entire model.

Additional functions are:

Add Body Add a body, which later can be assigned to polygons.

Add Value Add a physical parameter. Available parameters:

• Density (units t/m3, kg/m3 or g/cm3)

• Density Standard Deviation (see Section 5.3.1 on page 76)

• Königsberg ratio (SI)

• Remanent Declination (degree)

• Remanent Inclination (degree)

• Susceptibility (SI)

• Susceptibility Standard Deviation (see Section 5.3.1 on page 76)

Conversion between Susceptibilities from cgs in SI is given by:

Susceptibility (SI) = Susceptibility (cgs) * 4 * π.

Right mouse click on the header of a column shows a window to set either all values to the same value, or

add a constant to all values:

The unit can not be changed in the Body Manager, use Edit > Preferences (Section 4.2.2.3 on page 29)

to change the units.

5.3.1 Inversion

IGMAS+ provides an inversion of physical parameter(s) (densities or susceptibilities) using minimum

mean-square error (MMSE) estimation (refer to Sæther 1997 or Haase 2008 for a detailed discussion and

description). The approach is based on the reasonable assumption that all parameters and measurements

are Gaussian distributed. Hence, the initial guesses and the measurements are regarded as mean values

which are accompanied by their standard deviations (representing measurement errors and parameter
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variabilities, respectively). This inversion automatically fits a model’s calculated anomaly to the measured

one by optimizing the density and/or susceptibility.

Select Tools > Inversion or select the icon .

The inversion window on the left hand side lists all the anomaly fields with both, measured and calculated

fields. Select those fields which you want to be used for the inversion. If there is no measured and

corresponding calculated anomaly, there is no field to be selected, hence this inversion is not possible.

On the right hand side of the inversion window you see a list of all existing bodies as well as the Reference

’body’ (see figure above). In addition to the bodies name, the settings of the parameters ’Density STD’ and

’Susceptibility STD’ are shown.

Select the bodies which parameter is to be inverted. Select Next to start the inversion.

Parameters which affect the inversion results are:

Density standard deviation (Default is 5 t
m3 ). The value defines the variability of the density parameter.

Change this value with the Body Manager (Section 5.3 on page 75). If set to 0 (zero), this body

density is not inverted (default for reference density).

Susceptibility standard deviation (Default is 5 (in SI)). The value defines the variability of the

susceptibility parameter. Change this value with the Body Manager (Section 5.3 on page 75). If set

to 0 (zero), this body susceptibility is not inverted.

Chapter 5 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 77



Field error Changeable property of each anomaly field (Section 4.4.6 on page 44).

Auto Shift Changeable property of each anomaly field (Section 4.4.6 on page 44). This is a very important

parameter, if the inversion is based on gz, the vertical component of gravity. There are two constant

effects associated with a ’normal’ density model:

1. The vertical component gz is constant for a model block (= plate) of constant thickness,

2. The constant offset (shift value) between measured and calculated gravity, which is usually

automatically corrected (added to the calculated anomaly).

The inversion cannot resolve these two constant effects, if they are both inverted. Use the Auto Shift

property (Section 4.4.6 on page 44) to control the inverted constant. In both cases, the actual shift

value (anomaly offset) is added to the calculated gravity prior to inversion.

Auto Shift on In addition to the inverted result for any selected body density, aModel - Mean Value

is derived for the density.

Auto Shift off The residual gravity enters the inversion, which gives a result for any selected body

density. No Model - Mean Value is inverted for the density.

Please refer to Sæther 1997 and Haase 2008 for more information on the inversion method.

5.3.2 Absolute vs. Relative Physical Properties

You are completely free to use either absolute or relative density values. The calculated effect depends only

on the density differences at the modelled interfaces. One can prove this by using the Body Manager: add
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or subtract an arbitrary number (e.g. 100) to all density values (including reference density), and observe

the resulting anomalies. They do not change at all (see figures below). The same is true for susceptibilities.

Conclusion: In the case of normal density/susceptibility modelling one cannot determine the absolute

values of densities or susceptibilities. You will need to interpret borehole measurements in this case.
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5.4 Modification of Model Geometry

5.4.1 Shifting Vertices

Modify the position of vertices along the vertical section:

Single vertices, graphically Use [Shift]+ left mouse button to move the position:

Single vertices, alpha numeric Select vertex with right mouse button, from the menu select Alpha

numeric. Then enter x and z coordinate.

Group of vertices Mark a group of vertices using s and diagonal with left mouse button . Then

(holding [Shift] ) move all vertices by the same amount using the left mouse button .

If calculated anomalies are present and the Automatic Update is active, the anomalies are

updated automatically after performing the modification.

!
The triangulation may lose its optimal configuration. After serious geometry modifications it is

recommended to use the function Edit > New Triangulation again.

5.4.2 Inserting and Deleting Vertices

To insert new vertices, hold i and click left mouse button on the border of a polygon. A new vertex

will appear in this position.
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To delete a vertex, do the same on an existing vertex. Vertices should not be deleted if they have a node

position, this means, if they are connected to more than two bodies. In this case, you have to confirm the

operation:

5.4.3 Combining Polygons

This function combine or merge two existing polygons along a section. Select the 2-D View, along which

you want to combine the two existing polygons. Deactivate the Automatic Update button. Select the two

polygons which should be combine by pressing x together with the left mouse button and assign a

new polygon by using the right mouse button menu Combine polygon(s). The first selected polygon

will define the physical properties of the combined polygon.

Chapter 5 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 81



The new combined polygon inherits the physical properties and color of the first selected polygon. Select

Edit > New Triangulation to update the triangulation. Reactivate the Automatic Update checkbox.

5.4.4 Dividing Bodies

Divide an existing body into two parts in order to get a higher flexibility in assigning physical parameters.

There are two generally different divide-functions:

1. Divide a body along an existing section.

2. Divide a body perpendicular to the sections.

5.4.4.1 Dividing a Body along an Existing Section

Select the 2-D View along which you want to divide an existing body. Select the body to be divided with the

right mouse button, select Divide Body and then Finish. The selected body will be separated into two parts:

the new part inherits the physical properties of the old body, however its name will be extended by ’_new’.
The new body receives a new colour. Select Edit > New Triangulation to update the triangulation.
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5.4.4.2 Dividing a Body Perpendicular to the Sections

Deactivate the Automatic Update button. Hold d and draw a connection line between two vertices with

left mouse button (left figure below). The corresponding body will be divided along this line, its colour

will be highlighted by fading the rest of the bodies (right figure below). This procedure has to be done on

each section where the corresponding (highlighted) body exists.

Now add a new body definition using button Add Body in the Body Manager. Select all polygons which

should be assigned to the new body by pressing x together with left mouse button and assign the

new body using right mouse button menu Set Body(s).
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Use Clear Selection (right mouse menu) to deselect all the polygons. All new parts of the previous body

should be drawn with a new colour now:

Use Edit > Model - Triangulation or icon to update the triangulation. You are ready now.

The 3-D View should show the new body:
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If you get a triangulation error message and a 3-D View shows red (erroneous) vertices (see figure below),

you probably forgot to use the Set Body(s) to redefine all the polygons on each section. Repeat the above

steps until the model is correct.

Finally, use the Body Manager to assign a colour and physical parameter(s) according to your needs.

! Reactivate the Automatic Update checkbox after you are done:

5.4.5 Model Triangulation

The triangulation between two adjacent sections is performed automatically with the aim to build a 3-D

model geometry basing on polygons on vertical 2-D sections (profiles). The triangulated surfaces are called

interfaces (Section 4.4.2 on page 38), each one has a body defined on either side.
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This triangulation uses two steps:

1. The polygons on adjacent sections are split into body separating lines, connecting two nodes, where

a node is a vertex connecting more than two bodies:

2. The triangulation itself connects two corresponding parallel lines (line 1 with line 1, line 2 with line 2

etc., see figure above). The optimization criteria is to find the surface with the minimum surface area

among all possible triangulations.

Both tasks are done without any user interaction, but the critical point is to find the line pairs to be

triangulated between adjacent sections.

If the topology (i.e. the neighbour-structure) changes from one section to the next one, it might be

impossible to connect those sections by triangulation.
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Assume the situation shown in the figure above: It shows 2 adjacent sections, which have to be triangulated.

But how? In fact, this is impossible, because:

1. The gray caprock exists only on one of them

2. The blue Jurassic and the violet Triassic are subdivided into two parts on the first section, joined on

the next one.

To deal with this general problem, we have to assume a discontinuity in the structure perpendicular to the

section plane.

There are two ways to do it:

1. Doubly defined sections

2. Section mirrors.

5.4.5.1 Doubly Defined Sections

A discontinuity within one section. It has two different geometries on either side, defining a vertical fault:
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The existence of two polygons for the same body on the same section makes it necessary to make use of

the Body Part Indices (Section 5.4.5.3 on page 90) to distinguish between the different body parts.

Role of the Reference body: at the vertical end of a body with a discontinuity within one section, the

definition of the Reference body is required. The reason is because there is another geometry on the other

side of the section. The Reference body at both sides of the same section is a neutral medium, which

produces no anomaly.

5.4.5.2 Section Mirrors

A discontinuity somewhere between two adjacent sections, where its position is defined by two mirrors,

which extend the corresponding section geometry until its mirror. The mirror position is relative to the section

distance, between 2 adjacent sections only 0, 1 or 2 mirrors may exist. The following figure illustrates the
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four possible situations: No mirrors (top), 1 mirror on first section (top center), 1 mirror on second section

(bottom center), 2 mirrors (bottom).
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Edge mirrors The first and the last sections usually are located very far from the stations in order to avoid

an edge effect. It is not necessary with mirrors: assign Mirror− = −500 to the first section and

Mirror+ = 500 to the last section, and the model geometry will be extended by 500 m or km

(depending on the model units). After modifications it is recommended to use the icon in order

to clip the view to the model bounds. Alternatively, the function will clip the model’s view to the

stations bound.

Mirror units The mirror position is using fractions of the section distance, ranging from 0 to 1. The sum

of Mirror+ of section i and Mirror− of section i + 1 must be 1, except if they are both 0 (which

means: No mirrors used).

5.4.5.3 Body Part Index

Body part indices are used to assign the same body definition to geometrically separated bodies. Assume

the following situation (see figure below): the central layer of a model is separated into three parts, because

the central part (here coloured dark pink) has a different density to its surrounding.

Its left (red) and right (dark green) neighbours, however, belong to the same layer, although they are

geometrically separated. To model this situation, the Body Part Index is used: both polygons (the red and

the dark green one) are assigned to the same body, using an additional name (the ’body part index’) for

both polygons. This makes the triangulation unique.

There is no restriction to the number of body part indices for a polygon.
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The Body Part Index is shown and may be modified using the Property Editor of the polygons (figure

above). In addition it is listed in the ’mouse over’ information given for polygons in the 2-D Views.

To continue with the above example, we need the following steps:

1. Deactivate the Automatic Update button. Assign the same body to both polygons by selecting the

polygon ( x + left mouse button ), and assign the new body by using the right mouse button

menu Set Body(s).

2. Use the polygon editor to set the Body Part Index for each of the polygons (use names like ”right”

and ”left”).

3. Do the same for each polygon of both bodies.

4. Use Clear Selection (right mouse menu) to deselect all polygons and Edit > Model - Triangulation

or icon to update the triangulation. The resulting model will look like in the following figure:

! Don’t forget to reactivate the Automatic Update checkbox after your are done:
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The Body Part Index is saved in the model .model|.xml file as part of the polygon name separated by a
space character (blank).

Example:

<entry type="polygon" id_list="128 127 68 45 46 47 ">
<property name="body" value="B left"></property>

</entry>

5.4.6 Sectioning

Sectioning is a function to generate new vertical sections in order to get a higher flexibility for the structures.

The sections are calculated by cutting the complete triangulation with the section plane, and build polygons

out of the cross sections.

First, you should be sure, that the triangulation is up-to-date. In doubt, use Edit > Model - Triangulation

once. Then select Edit > Sectioning .

The wizard shows the area where your model is located. Change the values according to your needs:

Number of sections Click on - (to decrease) or + (to increase) and on dist to set the distance between

sections.

Location of first section Either move the green circle, or click the green circle with right mouse button to

use alphanumeric input.
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Location of last section Either move the red circle, or click the red circle with right mouse button to use

alphanumeric input.

Direction of sections If the existing model has already sections, the direction cannot be changed. If the

existing model does not have sections, click on the arrow and choose the direction according to your

needs (see Section 4.4.3 on page 39). The default direction of the model sections is parallel to the

x-axis.

Select Finish once you are ready. Run Edit > Model - Triangulation again to update the triangulation.

Hint 5.1

If you have a model, but you would like to change the direction of the sections, remove all the

sections (in the Object Tree click the right mouse button on the corresponding section), and

run Sectioning using another section direction.

!
The success of Sectioning strongly depends on the modelled structures. Keep in mind, that the

topology of the structures should not change between the two sections. Refer to Section 5.4.5 on

page 85 for a detailed discussion of valid topologies.

5.4.6.1 Special Case: Magnetic Measurements

In general, if measurements were obtained over profiles, the model sections can be oriented parallel to

the measurement profiles. For example, if magnetic measurements were obtained over profiles which are

not parallel to the x-axis with an azimuth α (see figure below), you can define the direction of the model

sections by changing in α the arrow position. In this case IGMAS+ will use for the calculations of magnetic

anomalies the magnetic declination β (parameter declination, see Section 4.4.7 on page 46).
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In case that the measurements were obtained over profiles with an azimuth α but, you would like to use the

default direction of the model sections parallel to the x-axis, we recommend you to follow this instruction.

For the calculation of magnetic anomalies is necessary to transform the magnetic declination into a magnetic

declination D for calculations in IGMAS+. The figure indicates how to transform the magnetic declination

β into the declination for calculation D taking into account the measurements direction α.
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5.5 Calculation of Anomalies

Calculation of the anomalies requires the following:

1. Model geometry including triangulation (interfaces)

2. Physical parameters (density and/or susceptibility)

3. Stations with coordinates (x, y, z) in the modelling area.

To start the calculation, select Tools > Calculate Anomalies . Alternatively you can select the icon .

The following window will list the fields which may be calculated (see Section 4.4.6 on page 44 for a list). The

calculation will start immediately after clicking Finish using the algorithm published by Götze and Lahmeyer

1988. The algorithm allows to calculate the effect on gravity or magnetic of a homogeneous polyhedron by

transforming a volume integral into a sum of line integrals (see Section 6.1 on page 122).

The anomalies are calculated for each interface (set of triangles separating two bodies, see Section 4.4.2 on

page 38) and each station separately and then summed up.

If at least one field has been calculated already, it is possible to use the same function again in order to

select more fields. The already calculated fields will be shown ’checked’ (unchecking is not possible):
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After modifications of either the model geometry or the physical parameters, the anomalies should be

updated automatically without user interaction. If this is not the case, or in the following cases

• when Automatic Update is unchecked:

• after initialisation of a voxel cube (Section 5.8.1 on page 103)

the ’traffic light’ will show ’yellow’ (Section 4.1 on page 26) and recalculation has to be initiated manually

using Tools > Re-Calculate Anomalies or the icon .

To save the calculated anomalies use Edit > Save > Save Anomalies .
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5.6 Adding a New Body

Task: I have a model with 3 layers named from top A, B, C, basing on 7 sections (see figure below). How

can I create a body within the central layer, starting not with the first and ending not with the last section?

Let us assume that the new body should start on the 2nd and end on the 4th section.

Then follow these steps:

1. Visualise the 2nd section in 2-D View.

2. Click right mouse button on the body to be divided (blue).

3. From the right mouse button menu select Divide body.

4. Click Finish on the message ’Divide Polygon [B] on Section 2’.

5. Do the same for the 4th section.
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6. Use Edit > Model - Triangulation to complete the divide operation.

The blue body B is now divided into 3 parts, which are named and coloured automatically. The physical

parameter(s) of body B are transferred to the new bodies:

• Body B between the first and the 2nd section

• Body B_new between 2nd and the 4th section

• Body B_new_new between the 4th and the last section.

7. Both ’divided’ sections 2 and 4 now have two different sides. View both sides (showing 3 different

colours for the central polygon) in the 3-D View by rotating the model:

8. Visualize it in the 2-D View by selecting View > Show Section Front > Show Section Back . A

direct access to toggle the back/front view is the 2-D View toolbar.

.
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9. The next step is to divide the body B on each of the sections between the 2nd and the 4th section into

3 parts:

(a) Go to the back view on the 2nd section.

(b) Deactivate the Automatic Update button: .

(c) Draw with the left mouse, holding key d (=’divide’), a separation line from one vertex to another

vertex, marking the division line.

(d) Do the same on the right border of the new model to be created. The body to be divided is

marked by deactivation of the rest of the bodies, as shown in the following figure:

.

(e) Do the same on section 3 and the front of section 4.

10. Finally create 3 new bodies for the left, the central and the right part of the previous body B_new:

(a) Use Body Manager → Add body.

(b) Use e.g. the names ’B_new_left’, ’D’ and ’B_new_right’.

(c) Select the 3 left polygons on sections 2 (back), 3 and 4 (front) selecting the polygon

simultaneously with x .

(d) From the right mouse button menu choose Set body(s) → B_new_left.

(e) Do the similar procedure for the central and the right body part.
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.

11. Triangulate ( Edit > Model - Triangulation ), clear selections with right-mouse-button menu entry

Clear Selections and don’t forget activate the Automatic Update button again: .

Hint 5.2

The procedure described here creates 5 separated bodies out of the previous body B: B, B_new,

B_new_new, B_new_left, B_new_right and D (see the following figure). They have different names,

and they may have different physical parameters.

If you want to keep your model as clear as possible, use the Body Part Index (Section 5.4.5.3 on

page 90) to assign the same body definition to geometrically separated bodies.

Without body part indices (left figure) and with body part indices (right figure):

. .
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5.7 Using Remanent Magnetism

In order to illustrate the use of remanent magnetism, we use models published by Reynisson et al. 2009

using IGMAS+.

The construction of synthetic models and calculation of the remanent magnetic response of models with and

without volcanics provides means to visualize and estimate the effect of volcanics on magnetic data.

Two synthetic models were constructed to characterize sedimentary basins in different geological settings:

The control model represents a basin in a non-volcanic environment and the test model is influenced by

volcanics. The test model was constructed to represent a basin influenced by basalt flows and intrusive

sills. The models have the same basement structure and differ only in respect to emplacement of volcanic

material of high magnetization.

These synthetic models are a simple representation of the Møre margin, which is part of the mid-Norwegian

margin that has been strongly affected by volcanism (Reynisson et al. 2009).

Both models have a basin that is overlaid by 2 km of water and 2 km of Cenozoic sediments. It is filled with

Mesozoic sediments with a maximum depth of 18 km deep and is 300 km wide and 400 km long. The basin

is underlaid by a magnetic basement that has four prominent highs and is symmetric about the deepest part

of the model. The greatest structural variations are in the X-direction but the basin shallows progressively

in the Y- direction from the deepest point and hence has 3D characteristics. The base of the basement was

kept flat at depth of 20 km. The basement is underlaid by nonmagnetic mantle. In the control model only

the basement has magnetic properties and has susceptibility of 0.01 (SI) and the remanent magnetization

is equal to the induced magnetization (Könisberg Ratio = 1).

In the test model, the basin is partly overlaid by a 1 km thick basalt layer and intruded by a sill at 7 km

depth that is 100 m thick in the centre of the basin and thins to zero towards the edges. The basalt layer has

a constant susceptibility of 0.01 (SI) and remanent magnetization that has the same polarity as the induced

magnetic field but twice the intensity (Könisberg Ratio = 2). The sill has a susceptibility of 0.03 (SI) and the

same remanent magnetization as the basalt layer. The orientation of the basin and the induced magnetic

field was configured to represent the present settings on the mid-Norwegian margin where the inclination is

about 75◦, declination is 0◦ and the total normal magnetic field is 50.000 nT.
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The difference between the total remanent field anomalies of the control model (first model) and the test

model (second model) demonstrates that the sills have a minor effect on the magnetic signal. The greatest

effect is in the centre where the sill is thickest and overlies the deepest part of the basin.

Superposition of the two volcanic sources severely disturbs the magnetic response of the underlying basin.

The sill does not produce disturbances at its edges due to the very gradual thinning of the sill towards its

edges. The overlying basalt has a larger impact on the magnetic signal and the internal magnetic variation in

the basalt further diffuses the image of the underlying basin. There is no indication of the small sub-basaltic

basin on the magnetic data from the test model and the indication of the sub-basaltic basin is considerably

diminished.
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5.8 Voxelization

A voxel model or voxel cube is used with the intention to locally change the density structure defined by

a conventional triangulated IGMAS+ model. The anomaly effect of both models (IGMAS+ model and voxel

model) is calculated independently and later added for each station.

A typical application would be to define a depth-depending or laterally changing density function to a

sedimentary body, as shown in the figure above: the colors indicate varying densities for the uppermost

density cover.

The voxel function may also be used to calculate the anomalies of an imported seismic velocity cube, applying

a function for the conversion of velocities into densities. If only the effect of an imported voxel cube has to

be calculated, the simplest IGMAS+ model, a cube, might be defined with constant density set to 0.

!
Only one voxel cube may be defined in addition to the IGMAS+ model. You may remove it by clicking

on it with the right mouse button, then choose remove. The voxel definition as well as the anomaly

effect will be eliminated automatically.

5.8.1 Initiation of a Voxel Model

There are two possibilities to initiate a voxel model:

1. Create a voxel cube using gridding

2. Import a voxel cube.

! The existence of an IGMAS+ model is required in both cases.

5.8.1.1 Creation of a Voxel Cube using Gridding

To perform voxelization (gridding) of an existing IGMAS+ model use menu entry

Research > Voxelize Model or the icon
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You will get a new window (see figure below). Define the extent and the resolution of the voxel model, as

well as the Cube Type : Density or Susceptibility.

! The maximum cube size is 20 Mio cells.

! The cube has to be parallel to the axes.

5.8.1.2 Importing a Voxel Cube

User can import a voxel cube defining one value per cell using menu entry File > Import > Voxel Cube .

The cell value might define either a density value, or might be used to calculate a density using a predefined

or user-defined function.

User needs to:

• Choose the file and the units of the coordinates.

!
The file must have file extension .vxo. The voxelisation wizard shows deactivated fields for
voxel cube extension and resolution, as these values are defined by the coordinates in the file.

• Choose the Cube Type (Density or Susceptibility).

The customisation window pops up automatically (see figure below). It shows list of all bodies of the IGMAS+

model. You may assign a function to each body (refer to Section 5.8.3 on page 106). If several bodies require

the same function, use the checkboxes and the Equation Settings together with Apply to define them all

at once. The density units are always identical to the units used in the IGMAS+ model.
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! The density functions may be changed later using the Property Editor for the bodies.

The gridding of the model will start, which means, that the position of each voxel cell within the IGMAS+

model structure is determined.

!
Depending on the computer perfomance, the number of cells and the complexity of your model this

may take some time. The computing time does not depend on the number or type of functions defined.

The progress is shown in the progress bar: after having finished the gridding, the voxel cube is displayed

automatically.

!
The anomaly of the cube is not calculated automatically, use function Recalculate Anomaly if you

already entered stations.

5.8.2 Visualisation and Control of the Voxel Densities

The voxel cells are displayed in density color mode, using the effective density, which is defined by the

sum of the density within each cell and the density of the underlying body. Use the tab Cursor Tracking to

display all three density values at the cursor position (left figure below).

The ColorBar tab shows the color scale used, indicating the values of the densities at the cursor position:

for IGMAS+ density it is a red triangle and for Voxel density it is a yellow triangle (right figure below).
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! Cells with effective density value equal to 0 are not displayed at all.

5.8.3 Using Density / Susceptibility Functions

Voxel elements are used to alter the densities which are constant within each body. Their density values

(and consequently their anomaly effects) are added to the ”normal” values / effects of the IGMAS+ model:

The following densities are defined at each voxel:

• IGMAS+ density (constant body density)

• Voxel density (defined through voxel function, multiplied with voxel factor)

• Effective density (the sum of IGMAS+ and voxel densities)
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The functions are defined for each body separately during voxel initialisation (Section 5.8.1 on page 103),

but may be modified later any time.

The following variables may be used:

X, Y, Z Coordinates of the center of each voxel cell element

ZMIN Minimum Z of vertices of corresponding body

ZMAX Maximum Z of vertices of corresponding body

ZTOPO The depth below the bathymetry interface (see Section 5.8.6 on page 109)

DENSITY The density (absolute or relative, according with your current model) of the corresponding body.

SUSCEPTIBILITY The susceptibility (absolute or relative, according with your current model) of the

corresponding body.

CELLVALUE For imported voxel cubes only: the cell value (4th column in the input file)

!
The equations are evaluated (converted to a density value) after each modification of the voxel

equation. All variables (except the coordinates and CELLVALUE) may be affected by interactive

modifications, and thus the equations have to be updated from time to time.

Function that are predefined in IGMAS+ are listed in Table 1 on page 107. Equations assume the following

units: z in km, ρ in t/m3.

Table 1: Predefined Voxel Equations

Description Formula IGMAS+ input

Default: No effect of the cells ρ = 0 0
Depth z to density ρ

(Compaction)

ρ = 2.65− 0.45e0.65z 2.65-0.45*exp(0.65*z)

Velocity vp to density ρ ρ = 1.74v0.25p , vp in km/sec gardner(cellvalue,1000)
(Gardner et al. 1974) ρ = 0.31v0.25p , vp in m/sec gardner(cellvalue,1)

ρ = 0.23v0.25p , vp in ft/sec gardner(cellvalue,0.3048)

Velocity vp to density ρ ρ = 1.6612vp

nafedrake(cellvalue,factor)
(Nafe & Drake) −0.4721v2p + 0.0671v3p

−0.0043v4p + 0.000106v5p
The factor depends on the m/sec: factor=1
units of the imported vp km/sec: factor=1000

ft/sec: factor=0.3048
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!
The density functions may be modified at any time using Property Editor → Voxel Equation. The

anomaly (or anomalies) will be recalculated automatically after modification of a voxel function.

5.8.4 Using Voxel Factor

Each body is assigned a voxel factor (default value is 1). The density in each voxel cell within the

corresponding body is multiplied by this value. For instance, a voxel factor of 1.1 means that all

corresponding density values are increased by 10%.

You can access the factor via the Body Manager (see above) or via the Property Editor if you have selected

a body in the Object Tree. This way you can easily change the voxel densities belonging to the same body

without using the equation editor. The voxel factor may be inverted (see Section 5.3.1 on page 76).

The voxel factor is saved together with the voxel equation in the .xmlmodel file (Section 5.2.3.1 on page 67).
Example (value="1.1" being the voxel factor):

<property name="voxel equation" value="1.1">2.65-0.45*exp(0.65*z)</property>

5.8.5 Modification of Bodies after Initialization of the Voxel Cube

The density values of each voxel cell are stored internally as ”values”, so that later modifications of the

eventually used variables DENSITY, ZMIN or ZMAX will not affect the voxel cell densities. In this case once

can force re-evaluation of the voxel equation (using the equation editor). Modifications of the geometry of

the bodies, however, will cause the link between each voxel to the body to be re-defined (regridded) (see

Figure).

Chapter 5 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 108



This will change the voxels density in the affected area in the following cases:

• If the functions are using body-dependent variables, (eg. DENSITY, SUSCEPTIBILITY, ZMIN, ZMAX,

ZTOPO).

• If the affected adjacent bodies have different voxel equations.

5.8.6 Using Bathymetry

The variable called ZTOPO (Section 5.8.3 on page 106) is used to include the depth below bathymetry within

the voxel function.

Use the following procedure to define this interface (see figure on the right hand side):

1. Use right mouse on Interfaces, then Add Category. Choose ”Bathymetry”.

2. A new interface ”Bathymetry” will appear in the list of interfaces.

3. Move one or more interfaces (drag and drop) into this new category. The z-value of these interface(s)

will define the bathymetry ZTOPO in the model area.

Chapter 5 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 109



If there is no bathymetry interface defined at a given voxel position (X, Y), the default is ZTOPO=0. If

there is more than one bathymetry interface defined at a given voxel position (X, Y), the depth of the lower

interface will be used.

5.8.7 Voxel Properties

! Voxel functionality require additional plugins, see Section 2.2.4 on page 19.

The cube properties are shown in the property editor (see figure above):

Transparency The transparency of the voxels 2-D and 3-D Views. The voxel visualisation may be switched

off totally by unchecking the voxel cube in the control window (Section 4.1 on page 26).

Cube Type May be ”density” or ”susceptibility”.

Algorithm Method to calculate the voxels anomalies: Newton Mass Points (default), Newton FFT, OpenCL

Point Mass, OpenCL Prism and CPU Prism. Refer to Section 5.8.9 on page 111.

Use Cube Anomaly (Checked) The anomaly(ies) of the cube voxels will be added to the anomaly(ies) of

the IGMAS+ model.

Use Cube Anomaly (Unchecked) The anomaly(ies) of the cube voxels will be calculated or updated, resp.,

but they are not added to the anomaly(ies) of the IGMAS+ model.

minimize edge effect (Checked) The mean value of the anomaly(ies) of all voxels located at the border

will be subtracted from the anomaly(ies) of the voxel model. This function minimizes the edge effect

of the border voxels.
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minimize edge effect (Unchecked) The mean value is not subtracted.

Dimension Entire voxel cube dimensions (for information only).

5.8.8 Voxel Cube Geometry

The axes of the voxel cube have to be parallel to the axes of the IGMAS+ model, no rotation is possible.

5.8.9 Calculation of the Voxel Anomalies (o.o.d.)

IGMAS+ currently offers five methods to calculate the anomaly of a voxel cube:

5.8.9.1 Point masses

The anomalies are calculated using point masses which are positioned in the center of each cell. The volume

of the mass point is identical to the volume of the voxel cell. The formulas used are given in Section 6.1.5

on page 125.

!

The approximation of voxel cubes through mass points leads to erroneous anomalies, if there are voxels

in the vicinity of the stations. In the future versions all superficial voxels will be calculated using the

polyhedron formulation (Götze and Lahmeyer 1988), which is used elsewhere in IGMAS+. Until then

please make sure to have a vertical distance to the most superficial voxels of approximately two voxel

depths.

5.8.9.2 FFT

The FFT uses point masses in the center of each cell too, but does not calculate the anomaly directly,

instead it calculates the horizontal Fourier-Transform of the density distribution for each layer of the Voxel

Cube. This yields the wavelength spectrum of that density layer. Applying a filter to this spectrum will give

the gravity/gradient anomaly caused by that layer, also in spectral representation. The horizontal inverse

Fourier-Transform is then applied to the spectrum of the gravity/gradient anomaly to give the values of the

anomaly at points directly above the voxel cells. These points are all on a horizontal layer (its z-coordinate

may either be specified by the user or calculated as the mean z-coordinate of all stations). The gravitational

anomaly of the entire Voxel cube is the sum of the effect of all its layers. All (inverse) Fourier-Transforms

are implemented as Fast Fourier Transforms. This results in a significant increase in computation speed

compared to the masspoint method described above, especially if you use a large voxel cube. For further

information see Schmidt, Plonka, et al. 2011.

!
The voxel cells do not necessarily coincide with the location of the stations, thus interpolation is required

to give the values at the stations.

IGMAS+ offers 3 interpolation methods: Nearest Neighbor, Average and Mundry.
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Furthermore, the fact that the results of this method are all placed on a horizontal surface means that one

would have to perform a field-continuation to include the effect of station height correctly, which IGMAS+

does not. Keep this in mind if results acquired with this method are implausible. In case of high variability

of topography you might have to use the usual mass point method instead.

5.8.9.3 OpenCL Point Mass

This method represents the Mass point method in the domain space, using the volume of each voxel and a

constant density. The methodology uses OpenCL Stream-Computing.

5.8.9.4 OpenCL Prism

OpenCL calculation of the gravitational attraction of a right rectangular prism, based on Nagy 1966.

5.8.9.5 CPU Prism

The method is based on the prism algorithm of Nagy 1966 using CPU performance.

! The voxel colors are sometimes incomprehensible.

! The susceptibility cube has never been tested!
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5.9 Calculation of Load and Stress

! This function requires the VerticalStress Module plugin (Section 2.2.4 on page 19).

The lithostatic pressure within point P (x, y, z) is defined through the force of the overlying mass column on

a unit area A:

P (x, y, z) = mg/A

with m = Mass of the column above the calculation point (x, y, z)

g = Gravity in the calculation point (x, y, z)

With m = ρV olume = ρhA we get Pascal’s law:

P (x, y, z) = ρhg

with ρ = Density of the mass column

h = Height of the mass column

g = Gravity in the calculation point (x, y, z)

If the mass column contains more that one density, the sum of all parts has to be calculated (see figure

above):

P (x, y, z) = gΣρihi

The SI unit of P (pressure, stress) is kg/ms2

Usually geophysicists use ’Mega-Pascal’: MPa = 106Pa = 106kg/ms2 = 106N/m2 and call it stress (σ).

Pascal’s law may be evaluated easily in each point of a density model, as only the density and the thickness

of each layer above the calculation point is needed and summed up (see figure above). The gravity g is

considered to be constant throughout the entire model area, its value (default is 9.81m/s2) may be changed.
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The algorithm described yields the vertical stress σzz. For most purposes, however, σn is needed, which

is the normal component on a reference surface with a certain angle α to the horizontal (see left part of the

figure above):

σn = σzzcos(α)

A horizontal reference surface means of course σn = σzz, as α = 0.

5.9.1 Horizontal Stress

Once the stress is separated into components, we can introduce horizontal stress in addition to the vertical

stress defined so far (see right figure above):

σn = σzzcos(α) + σhsin(α)

The horizontal stress σh does not depend on the density structure and therefore is not derived from the

density model. If the horizontal stress is known, it may be introduced as a constant vector (defined by

azimuth and magnitude) throughout the model in the Stress Settings window (see Section 5.9.4 on

page 116). It is added vectorially to the vertical stress (see figure above).

Default value for horizontal stress: σh = 0MPa
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5.9.2 Role of the Reference Density

The load stress is calculated using the following simple algorithm:

σzz = gΣρihi

The reference density is the density, which surrounds the entire model block (see figure on the right hand

side). If we subtract the reference density from each single density value, we define our model ’relative

to’ the reference density.

! Note that the shifted gravity anomaly does not change!

The above equation then looks like: σzz = gΣhi(ρi − ρref )

σzz = g(Σρihi − ρrefΣhi))

From this formulation it is obvious, that the reference density (if it is not equal to 0) is used to subtract

a ”normal” crust from surface to the reference surface with constant density ρref in order to derive stress

anomalies.

5.9.3 Gravitational Potential Energy

The gravitational potential energy (GPE) per unit area A is defined as GPE = mgh/A With m = ρhA we

get GPE = ρgh2 If the density of the mass column is inhomogeneous, we use piecewise constant densities

throughout the entire mass column: GPE = gΣρih
2
i The unit of GPE is kg/s

2 = Joule/m2 = N/m.

If we compare the definition of GPE with the definition of the stress σ, we see, that: GPE = Σσihi with σi

being the stress contribution of layer i, which has constant density ρi throughout its entire thickness hi.

In environments of constant density, the stress is increasing linearly with depth and the GPE is increasing

quadratically with depth.
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The figure below shows vertical profiles of density (left), vertical stress (centre) and gravitational potential

energy GPE (right) across a density discontinuity.

5.9.4 Vertical Stress Calculation

Select menu entry Create/Update Stress . The stress settings window will appear with two tabs:

Station - Topography Density See Section 5.9.6 on page 119 (default: 0).
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Constant Depth Constant depth of target surface, if no reference surface (Section 5.9.5 on page 118) is

used (default: Maximum depth of the model).

Gravity Gravity to be used for pressure calculation (see above, default: 9.81m/s2).

Use Reference Surface If a reference surface is defined (Section 5.9.5 on page 118), it may be used or

not. If unchecked, the constant depth is used as a reference surface (default: No).

Effect Choose the field to be calculated (choose between σn, σzz or GPE).

Horizontal Stress - Angle to North Degrees, positive clockwise (default: 0).

Horizontal Stress - Magnitude Magnitude given in MPa (default: 0 MPa).

Grid - X, Y Origin of the calculation area (default: bounding box of the model).

Grid - Width, Height Size of the calculation area (default: bounding box of the model).

Grid - dX, dY Grid cell size (default: depends on area, cell number is 50× 50).

To start calculation, choose OK. Depending on the size of the model and the number of grid cells of the

calculation area, the calculation may take some time.

The progress-bar is indicating ’busy’ until the calculation is finished (Information ’Finished Calculation of

LOAD Map’).

Display the stress map by selecting either Add View > 2D Maps View or , or using Fields → Stress

Map in the Object Tree for a 3-D View.

The figure below shows the result for the Salt-Example: the stress σn calculated using the reference surface

”Tertiary / Cretaceous”, and visualized in the 3-D View (bottom) and as the 2-D Map (top).
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!
The stress field and map is not updated automatically after geometry of density modifications, as the

calculation may take considerable time. Use Create/Update Stress button to update it.

!
If a voxel cube of density type is present, and its property Use/invert cube anomaly is switched

on, the voxel density contribution is added to the stress effect (see Section 5.8 on page 103 for more

information).

5.9.5 Reference Surface for Stress

The default reference surface is a horizontal surface in the maximum depth of the model. It is possible

to choose any depth or any non-horizontal reference surface out of the interfaces defined in the IGMAS+

model.

Use the following procedure to define this reference surface:

1. Use right mouse button on Interfaces in theObject Tree, then Add Category. Choose ”Stress

Reference”.

2. A new interface ”Stress Reference” will appear in the list of interfaces.

3. Drag one or more interfaces into this new category. The z-value of this interface(s) will define the

target reference surface for the stress calculation.
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! The stress is not calculated outside of the area of the stress reference surface.

Any non-horizontal reference surface will cause the normal stress to be smaller that the vertical stress:

σn = σzzcos(α)

5.9.6 Topography and Isostasy

If gravimetric modelling is done on the base of the Bouguer Anomaly which should be topographically

corrected, the topographic surface is not a part of a density model. On the other hand, the topography has

a considerable influence on the vertical stress field. This is especially important in the context of isostatic

investigation, where topography and underground density structure are set into a certain relation.

To take the topographic surface into account, the station elevations are used. Thus, the vertical stress field

of a virtual topographic body is added to the total stress:

Use the parameter ’Station-Topography Density’ (Section 5.9.4 on page 116) to include the load of the

topographic masses (default value is 0). As the topographic effect is derived from the station elevation, it

can be calculated only in areas, where stations with known elevation are existing. Outside the station areas

the elevation is assumed to be 0.

5.9.7 Export Stress Map

Export the calculated stress map data using File > Export > Export StressMap . An ASCII file (.csv)
will be created with the following content (after a couple of header lines):
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Column 1-3: Coordinates x, y, z (in model units)

Column 4: Angle α on reference surface

(in degree)

Column 5: Actual field (σzz, σn or GPE,

depending on settings).

#LoadMap Header Information [start]
#unit_length=m
#unit_pressure=MPa
#unit_angle=degree
#bounds=(x=0.0; y=-1.9999999494757503E-4; w=20.0; h=12.000199999994948)
#sigma_h=0.0; 0.0
#dx=400.0
#dy=240.00399999989895
#NO_DATA_VALUE=-9.999E20
#LoadMap Header Information [end]
"200.0";"119.802";"-1395.6363";"2.9267772073945015";"-2.0064766152925433";
"200.0";"359.806";"-1395.6363";"2.9267772073945015";"-2.0064766152925433";
"200.0";"599.810";"-1395.6363";"2.9267772073945015";"-2.0064766152925433";
"200.0";"839.814";"-1395.6363";"2.9267772073945015";"-2.0064766152925433";

.... followed by a number of rows...

Exact file layout depends on the .csv settings. Please refer to the .csv description for further details on
this format (Section 6.3.1 on page 132).
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5.10 Model Extension (t.b.e.)

An edge effect, which is due to the laterally limited modelling area, is observed. If a constant density is

assumed outside the modelling area, there is a ”jump” in the modelled structures.
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6CHAPTER

Technical Information

“ Simple things should be simple, complex things should be possible.

”
Alan Kay

6.1 Algorithms

The default of the gravitational constant used for any gravitational calculation is

G = 6.67384 · 10−11m3/kg s2

Due to compatibility reasons, mantissa of this constant can be changed by the user via the property Triangle

Kernel of the entry Model (see figure below).

! The modification of the gravitational constant is valid for the current session only.

! Be careful, you might turn the gravitational anomalies into nonsense!
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6.1.1 Triangle Calculation

This section lists all available algorithms for triangle calculation and some background on how to improve

performance for interactivity.

For interactive work it is essential that after model changes the recalculation of the model is done

immediately. It is important that this performance is achieved not only when a single point in the model is

altered but also when bigger parts are changed at once (e.g., several triangles). The basis for a fast

recalculation is a changed-only recalculation (fortunately possible in gravity and magnetics):

1. Identify these parts of the model which have been changed

2. Subtract these effects from the actual field

3. Add the newly calculated effects.

One important aspect is the speed of the calculation of the gravity effect for triangles (single- and multi-z

surfaces). This can be achieved for example by parallelizing calculations on all available CPU-cores and/or

GPU via OpenCL (Alvers et al. 2014). Another way of speeding up the calculations is to approximate them.

Gaussian Quadrature can approximate the exact calculation of the surface integrals over the triangles, if

certain conditions hold. Approximations have to be applied carefully in order to prevent errors. For the

recalculation of the model (after model changes) this is often less critical. The introduced error of

subtracted and newly added calculation are quite often very similar and cancel out each other at least

partly. Parallelization and approximation can obviously be combined.

For high performance, cloud computing focuses on maximizing the effectiveness of available hardware

resources. Providing maximal flexibility to use available resources in the local intranet and the connection

to cloud providers enables users to perform calculations in much shorter timeframes with – in the case of a

commercial cloud provider – often limited financial resources.

Depending on the available hardware educated choices on what algorithms should be applied has to be

made.

IGMAS+ offers 6 different algorithms for triangle calculation:

1. Triangle Kernel (Multicore): Multicore implementation of Götze and Lahmeyer 1988, (Triangle Kernel).

2. Triangle Kernel (OpenCL): OpenCL implementation of Götze and Lahmeyer 1988, (Triangle Kernel).

3. Triangle Kernel (Cluster): executes the implementation of Götze and Lahmeyer 1988 (Triangle Kernel)

on a cluster. See Section 6.4 on page 142.

4. Gaussian (Approximation) Quadrature (Multicore): Multicore implementation of triangle

approximation using 3 points Gaussian Quadrature.

5. Gaussian (Approximation) Quadrature (OpenCL): OpenCL implementation of triangle approximation

using 3 points Gaussian Quadrature.
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6. Mix exact and approximated (Multicore): This algorithm mixes exact and approximate calculations

of Gaussian Quadrature using multicore. Two properties are taken into account to select the exact

calculation of triangles:

a) a threshold for maximum triangle areas (in model units)

b) an error threshold for automated error estimation (in mGal), minDepth (in model units).

That means for deeper parts of the model the calculation can be approximated by Gaussian Quadrature.

6.1.2 Calculation of Invariants, Horizontal Gradient and Horizontal Directive Tendency

The invariants Inv0, Inv1, Inv2 are combinations of gravity gradients components, which are the second

derivatives of the potential. The interpretation of invariants could give information about of the more

high-frequency part of the anomaly. Calculations of invariants and gradients are based on Pedersen and

Rasmussen 1990.

Inv0 = Gxx +Gyy +Gzz

Inv1 = GxxGyy +GyyGzz +GxxGzz −G2
xy −G2

zy −G2
zx

Inv2 = Gxx(GyyGzz −G2
yz) +Gxy(GyzGxz −GxyGzz)

+Gxz(GxyGyz −GxzGyy)

The horizontal gradient and the horizontal directive tendency are given by:

HGz =
√

G2
zx +G2

zy

HDT =
√

(Gxx −Gyy)2 + (2Gxy)2

6.1.3 Mundry Interpolation (t.b.e.)

Interpolation algorithms are based on Mundry interpolation (Mundry 1970).

6.1.4 Block Average Filter

This function is applied, if irregularly distributed point data are imported, and due to highly oversampled

number of points, they have to be down-sampled during import.

Used in function Import of single z horizons (Section 5.2.3.3 on page 69).

Method: The area covered by the points to be imported is covered with regularly spaced vertices. During

import, each imported point is assigned to the nearest regular vertex. Finally for each vertex the average

of all 3 coordinates (x, y and z) is calculated, and only these average values are stored and used.

Advantage: The averaging within vertex surrounding is calculated successively during import procedure,

so that the memory needed does not depend on the number of the points to be imported.
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6.1.5 Mass Points

The following equations are used for the calculation of the voxel effects. Each voxel is approximated by a

sphere with its volume being identical to the volume of the voxel.

Chapter 6 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 125



6.1.6 Triangulation (t.b.e.)

Triangulation is a subdivision of a planar object into triangles (or simplices in a higher-dimension geometry).

6.1.6.1 Triangle Orientation

A triangle has right and a left hand side, depending on the order of the vertex definition:

Each triangulated surface has one body on its right and another body on its left hand side. Remember the

Right Hand Rule:

If the fingers follow the order of the vertices (1 → 2 → 3), the thumb

shows the direction of the positive normal (the right hand side).

Usually the user should not be concerned about the triangle orientation - it will be chosen correctly by

IGMAS+. However, if a triangulation is imported from another program (e.g. GOCAD TSurf’s, see

Section 6.3.6 on page 138), it might be necessary to think about the orientation.

TheObject Tree shows the orientation of each interface: it shows two body names for each single interface,

which are separated by the body separator <>. The first name (left!) specifies the name of the body on the

left hand side, the second name (right!) the body on the right hand side.

6.1.7 Extraction of Isosurfaces from Voxel Cubes

A voxel cube may be transformed into triangulated isosurfaces. After selecting the icon the following

wizard will appear:
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Set the limits for the cell values to be included (lower and upper limit) and choose, whether the bodies are

to be closed at the model boundaries.

Using ”Mesh Simplification” will reduce the number of triangles after geometry extraction.

! The function uses the Marching Cubes algorithm.
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6.2 Units and Coordinate System

IGMAS+ is using the following coordinate system (ENU system, see figure below):

x positive to the East

y positive to the North

z positive to the top (Up)

Units may be either Meters (default) or Kilometers (change in Edit > Preferences , Section 4.2.2.3 on

page 29).

For the modelling it is not necessary to use a special geographical projection, the only prerequisite is an

orthogonal coordinate system - which may be any projection.

However, if you plan to visualize the model and the anomaly fields using WorldWind, you have to specify the

correct projection.

Use the Property editor tab of the Object Tree entry Model to get the projection definition:
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6.2.1 Projection Coordinates: unknown (default)

Use this setting, if you don’t know the coordinate system, if you use local coordinates (not referred to world

coordinates) or if you are not interested in a visualization with WorldWind.

6.2.2 Projection Coordinates: Mercator

The Mercator projection is the easiest way to transfer spherical (geographical) coordinates into plane

(orthogonal) coordinates. Use the following transfer functions - they are exact and easy to use:

Forward (spherical into orthogonal):

x = (λ− λ0)

y = 0.5 · ln
(
1 + sin(φ)

1− sin(φ)

)
Here λ and φ are given in radians. x and y are normalized with the Earth radius, so multiply x and y with

6378137 to get Meters or 6378.137 to get Kilometers.

Reverse (orthogonal into spherical):

λ = λ0 + x

φ = arcsin(tanh(y))

!
The Mercator projection (used for rendering maps in Google Maps, OpenStreetMap, Bing etc.) is most

accurate in the area of low latitudes, it cannot be used in polar regions.

The EPSG code (see Section 6.2.5 on page 130) of this projection is 3857.

6.2.3 Projection Coordinates: Universal Transverse Mercator

The Universal Transverse Mercator (UTM) projection uses the Hayford ellipsoid.

The parameters are:

Reference meridian May be -177, -171, -165, ... +177 (degree).

UTM Zone May be 1 to 60. The zone is linked to the reference meridian via the following equation:

zone = (Ref.Mer.+ 183)/6

Hemisphere North or South (Default: North)

East Delta This value (in meters, default is 0) will be added to the model x-coordinates before

transformation into geographical coordinates.

North Delta This value (in meters, default is 0) will be added to the model y-coordinates before

transformation into geographical coordinates.
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6.2.4 Projection Coordinates: Gauss-Krueger

The Gauß-Krüger projection uses the Bessel ellipsoid.

The parameters are:

Reference meridian May be -180, -177, -174, ... +180 (degree).

Hemisphere North or South (Default: North)

East Delta This value (in meters, default is 0) will be added to the model x-coordinates before

transformation into geographical coordinates.

North Delta This value (in meters, default is 0) will be added to the model y-coordinates before

transformation into geographical coordinates.

6.2.5 Projection Coordinates: EPSG code

The European Petroleum Survey Group (EPSG) established a system to define and access all geodetic

coordinate projections used worldwide. The website http://epsg.io may be used to find the EPSG code
for a special projection.

Examples:

EPSG

code

Description

3857 WGS 84 / Pseudo-Mercator - Spherical Mercator, Google Maps, OpenStreetMap, Bing,

ArcGIS, ESRI

31466 DHDN, Gauß-Krüger Zone 2, Germany

31467 DHDN, Gauß-Krüger Zone 3, Germany

31468 DHDN, Gauß-Krüger Zone 4. Germany

24819 PSAD56, UTM Zone 19, Chile

If the EPSG code is used, the model coordinates have to be in Meters, and there is no additional offset for

the locations possible.
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6.2.5.1 PROJ.4 Definition

Each projection may be defined by a number of parameters and thus described by a single line definition -

called PROJ.4 (https://proj.org/, see also

https://live.osgeo.org/en/overview/proj4_overview.html).

Example: The description of the EPSG code 24819 (UTM zone 19) is:

+proj=utm +zone=19 +ellps=intl +towgs84=-288,175,-376,0,0,0,0 +units=m +no_defs

The PROJ.4 definition is given for each projection on the EPSG website, in addition it is always shown in the

IGMAS+ projection settings (see figure above). You may alter this line (EPSG code is set to 0 in this case)

to define your own projection.

6.2.6 Projection Coordinates: GeoTools (t.b.a.)
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6.3 File Formats (o.o.d.)

File format extensions used in IGMAS+ together with related functionality are presented in Table 2.

Function/Extension .csv .igmas .model .stations .xml .xyz

Load project +

Save project +

Open model + +

Save model + +

Load stations + + +

Save anomaly + + +

Export interfaces + +

Import xyz-grid + +

Import PointSet + +

Table 2: File extensions in IGMAS+.

Descriptions of file formats are given in Table 3.

Table 3: Description of IGMAS+ File Formats

Extension Format Description

.csv comma separated

value, ASCII

values in a .csv file can be exclusively separated by comma

[,], semicolon [;], blank [ ] or tab and may (but do not

need to) be embedded in quotation marks ["value"]; .csv

files may have one or no header lines

.dat binary data file Import and export of station data in a binary format

.igmas IGMAS+ project file

-deprecated-

load IGMAS+ and save an IGMAS+ project

.model|.xml IGMAS+ models, XML

type

IGMAS+ holds an internal Document Type Definition (.dtd)

for XML file validation. No external .dtd file is required.

.stations|.xml IGMAS+ stations, XML

type

IGMAS+ holds an internal Document Type Definition (.dtd)

for XML file validation. No external .dtd file is required.

.xyz XYZ grid data file

XYZ-grid

grid data for model geometry and point sets for e.g.

borehole data or Euler Depth. Three columns (x, y, z).

.vxo Voxel cube Similar to .xyz, but with 4 columns (x, y, z, value). Used for

voxel im- and export.

6.3.1 Point Data .csv

The comma separated value or .csv file format is a format used in IGMAS for ASCII point data like stations
(Section 6.3.4 on page 136), and interfaces (Section 5.2.6 on page 74). Each line in .csv files contains one
station with a fixed number of columns in each line.
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The following settings may be used:

separator comma [,] semicolon [;] tabulator [TAB] blank [space]

header Include or not a header line.

quotes Use quotes for numbers and/or header entries.

While loading, the settings used in the file will be recognized and used automatically. While saving, a wizard

will pop up and offer CSV settings (Figure 6.1)

Figure 6.1: Options to save .csv file in IGMAS+.

Units A .csv station file does not contain information about the units used. However, the .csv wizard
(Figure above) does give you the possibility to choose the units used from a list (available for Load as well

as Save).

IGMAS+ uses double precision (64bit) for measured values and single precision (32bit) for coordinates.

Example .csv file:

X;Y;Z;measured gravity;measured gzz
472;7968;0.129999995;14.5165615081787;-1.19159984588623
474;7968;0.129999995;15.8175678253174;6.28382110595703
476;7968;0.129999995;17.1463527679443;10.6069469451904
478;7968;0.129999995;16.2382793426514;0.371654510498047
480;7968;0.129999995;15.7985668182373;-0.996235847473145
482;7968;0.129999995;16.1438369750977;2.18927764892578
484;7968;0.129999995;16.5048122406006;-0.554471015930176
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Figure 6.2: Importing .csv with stations in IGMAS+.

The Header with descriptions about the stations and data can be included in the first line. In this case don’t

forget to select interpret Header in the wizard (Figure 6.2).

For changing the Value-Types, please click on table header and select the column value what you need

(Figure 6.3).

6.3.2 Point Data .xyz

The .xyz file format is similar to the .csv format. It is used for ASCII point data defining horizons

(interfaces) for the function Import of single-z horizons (Section 5.2.3.3 on page 69). Each line in .xyz
files contains one point using a fixed column order x, y, z. A header line containing ”X”, ”Y” and ”Z” will
be interpreted, but is not needed. If this header is missing, an additional window will ask for the columns

to be imported.

6.3.3 Voxel Cube .vxo

The actually only implemented file format is a column separated ASCII file (.csv-format with arbitrary

separator). It has to have the file extension .vxo.
The file may contain header line(s) marked with a #. The example below shows a voxel, as it was exported

by IGMAS. The header lines are not interpreted!
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Figure 6.3: Selecting a header while importing .csv with stations in IGMAS+.

The voxel file may contain additional (commenting) lines: Each line containing non-numeric information is

ignored without notice!

A special order of the cell elements is not required. The size of the cells has to be regular (constant)

throughout the file. The cell size is determined by the first non-zero difference between two consecutive

lines in x, y and z separately. Negative differences are taken positively.
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#VoxelCube Header Information [start]
#unit=km
#nx=80
#ny=48
#nz=36
#dx=0.25
#dy=0.25
#dz=0.25
#lower=(0.0, -0.0, -9.0)
#upper=(20.0, 12.0, 0.0)
#VoxelCube Header Information [end]
0.125;0.125;-8.875;0.25;
0.375;0.125;-8.875;0.25;
0.625;0.125;-8.875;0.25;
0.875;0.125;-8.875;0.25;
1.125;0.125;-8.875;0.25;
... followed by a number of rows...

! The number of voxel cells is limited - the maximum number is given in Section 2.1.2.3 on page 16.

Voxel cubes containing not constant cell sizes in z: The cube may be imported using a transformation

to a regular cell size. The voxel import wizard contains the line interpolate z-cells. Check this function to

transform the irregular cells into regular cells using the smallest cellsize of the original voxel cube

(Figure 6.4).

! Please note, that this transformation will result in a greater number of cells.

6.3.4 Station Files .stations, .xml, .csv

A station file contains the coordinates (x, y, z) or (x, y) and eventually measured data of the stations. Refer

to Section 4.4.5 on page 43 for more information on station data.

Load stations Use function File > Open > Load Anomalies to import the station data. This function is

only available if a model is present.

Save stations Use function File > Save> Save Anomalies to save those fields which actually are

selected in the Object Tree.

There are two different file formats possible:

.csv format See Section 6.3.1 on page 132.

Possible header entries are:
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Figure 6.4: Importing a voxel cube in IGMAS+.

"x" "y" "z"
"measured x component"
"measured y component"
"measured z component" (or "measured gravity")
"measured gxx"
"measured gyx"
"measured gxz"
"measured gyy"
"measured gzy"
"measured gzz"
"measured i0"
"measured i1"
"measured i2"
"measured magnetic x"
"measured magnetic y"
"measured magnetic z"
"measured magnetic tfi"
"measured magnetic tfir"

... ’measured’ may be replaced by ’calculated’ in the file, however, loading stations will skip
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calculated anomalies.

.stations, .xml The internally preferred .stations format is an xml format, which contains more
information that the .csv file, as it adds the coordinate system, the units etc.

After loading the stations, the model is automatically clipped to the station area using clipplanes

(Section 4.4.8 on page 47).

Here is an example of .igmas file for stations:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE geodata SYSTEM "geodata.dtd">
<!-- Created by Program column2xml - Author: Sabine Schmidt, CAU Kiel -->
<geodata>
<projection name="unknown" units="km" />
<vertex x=".00000" y="-.00020" z=".00020" >
<property name="Measured gravity" value="-1.63953" units="mGal"/>
</vertex>
<vertex x=".00000" y="1.00000" z=".00020" >
<property name="Measured gravity" value="-1.53329" units="mGal"/>
</vertex>
<vertex x=".00000" y="1.99980" z=".00020" >
<property name="Measured gravity" value="-1.43530" units="mGal"/>
</vertex>

</geodata>

6.3.5 IGMAS+ Models .model, .xml (t.b.a..)

6.3.6 GOCAD® Models .ts .tsurf

The GOCAD® TSurf elements which are interpreted are:

name: (in HEADER) Each interface separates two bodies, the names of which are separate by <>.

Example: Saltbody<>Mesozoic

The first body name (here: Saltbody) is assumed to be on the left hand side of the interface, the

second (here: Mesozoic) on the right hand side. Right hand side means: On the side of the positive

triangle normal.

Using Saltbody<>Mesozoic instead of Mesozoic<>Saltbody will flip the orientation of every single

triangle of the entire interface.

If the body separator <> is missing (eg. name: Saltbody), Saltbody<>Reference is interpreted.

*solid*color:RGBα (in HEADER) (red green blue transparency) values. Transparency is not interpreted.

The color is assigned to the body name to the left of the body separator <>.
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ZPOSITIVE (Elevation|Depth) Z-Coordinate positive to the top | to the bottom. Default is: Elevation.

AXIS_UNIT (”m” ”m” ”m” | ”km” ”km” ”km”) Default: ”m” ”m” ”m”

TFACE Start a new triangulated interface.

VRTX Keyword to identify lines with vertices, which contain of 5 columns:

VRTX id x_coordinate y_coordinate z_coordinate

ATOM Linked VRTX indices is interpreted

TRGL Keyword to identify lines with trianges, which contain of 4 columns:

TRGL id1 id2 id3

Orientation of the triangles: The orientation is assumed to be identical throughout the entire TFACE.

It is defined by the order of the triangle vertices with the right hand thumb-rule: The thumb is indicating

the positive triangle normal, if the fingers follow the order of the vertices (see more in Section 6.1.6.1 on

page 126).

Example Tsurf-file, defining a simple cube:
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GOCAD TSurf 1
HEADER {
name: reference<>new_body
*solid*color: 0.5019608 0.5019608 0.5019608 1
}
GOCAD_ORIGINAL_COORDINATE_SYSTEM
NAME: from_Shape
AXIS_NAME: "X" "Y" "Z"
AXIS_UNIT: "m" "m" "m"
END_ORIGINAL_COORDINATE_SYSTEM
TFACE
VRTX 7 0.0 0.0 0.0
VRTX 6 0.0 1.0 0.0
VRTX 5 1.0 1.0 0.0
VRTX 4 1.0 0.0 0.0
VRTX 3 1.0 0.0 -1.0
VRTX 2 0.0 1.0 -1.0
VRTX 1 1.0 1.0 -1.0
VRTX 0 0.0 0.0 -1.0
TRGL 0 1 2
TRGL 0 3 1
TRGL 3 4 1
TRGL 4 5 1
TRGL 4 6 5
TRGL 4 7 6
TRGL 7 2 6
TRGL 7 0 2
TRGL 4 0 7
TRGL 4 3 0
TRGL 5 6 2
TRGL 5 2 1
END

6.3.7 Wavefront .obj files

IGMAS+ reads and writes Wavefront .obj files, which is a plain ASCII text format. See more about this
format here.

The interpreted lines are:

v Keyword to identify lines with vertices, which contain of 4 columns:
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v x_coordinate y_coordinate z_coordinate

f Keyword to identify lines with trianges, which contain of 4 columns:

f id1 id2 id3
Lines with more than 4 columns (i.e. faces with more than 3 vertices) are not interpreted.

# Comments, not interpreted.

Example of a Wavefront .obj file defining a simple cube:

#vertex definitions
v 0.0 0.0 -1.0
v 1.0 1.0 -1.0
v 0.0 1.0 -1.0
v 1.0 0.0 -1.0
v 1.0 0.0 0.0
v 1.0 1.0 0.0
v 0.0 1.0 0.0
v 0.0 0.0 0.0
#Face: reference <> new_body
f 1 2 3
f 1 4 2
f 4 5 2
f 5 6 2
f 5 7 6
f 5 8 7
f 8 3 7
f 8 1 3
f 5 1 8
f 5 4 1
f 6 7 3
f 6 3 2

Chapter 6 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 141



6.4 Cluster and Cloud Computing (o.o.d.)

Configuring a private cluster for Newton Kernel calculation:

1. All computers on the local network running IGMAS+ will automatically became part of the private

cluster, making them available to accept calculation tasks.

2. Computers which don’t have an IGMAS+ installation can as well became parts of the private cluster.

In this case the cluster-node application has to be installed. This consists of a jar file which is always

running and waits for tasks. It is not using computer resources when it has no calculation tasks. It

can run as regular application or as a service.

3. Configuration file: by default the cluster node will use all cores of the computer for the calculation.

This can be limited using a settings file, called settings.conf.

Content: threadcount<tab><number of allowed calculation threads>

Placement:

In case of the cluster-node application, in the same folder where the jar file is (it is installed).

For computers running IGMAS+:

<user-home>/.igmas-cluster/ClusterWorker/settings.conf

4. Computers can be added and removed dynamically safely also during a calculation.
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The time estimation is based on the amount of processor cores and the individual characteristics of the

processor. As the computer have to share the resources with other tasks (like system processes) too, the

calculation time can be only given approximately.

Chapter 6 IGMAS+ User Manual v.1.4.8671 (2020-12-12) 143



6.5 Known Issues

• Issue: The model cannot be created due to its big size, IGMAS+ hangs and nothing happens.

Workaround: Check if the 64-bit version of JRE (see Section 2.1.1.1 on page 14) is selected in the

IGMAS+ JVM Settings ( Research > JVM Settings ):

Check if the amount of maximum heap size there is optimal. To optimize, click on Optimized button.

Restart IGMAS+ for changes to take effect. See also Section 4.2.5.1 on page 32.

• Issue: The model in the 3-D View is unfocused and has stripes:

Workaround: Enable force stereo rendering checkbox in the IGMAS+ settings

( Research > JVM Settings ).

• Issue: For certain Intel graphics cards the model elements in the 3-D View are wrongly visualized:
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Workaround: Try updating the driver for Intel graphics card or use NVIDIA graphics card if available.

You can force using NVIDIA card in NVIDIA settings applications.

• Issue: For certain Intel graphics cards, clipping of the extended interfaces does not work properly

in 3-D Views (left figure below), using the same graphics cards voxel visualization in 2-D Views is

erroneous (right figure below):

Workaround: Try using the Direct3D version or workaround from the previous issue.

• Issue: If you have set the Windows taskbar to Auto-hide before loading a model and station data,

IGMAS+ will possibly not respond or will not be able to show a good response time (related to the

Direct3D version).

Workaround: Disable the Auto-hide function of the Windows taskbar.
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• Issue: After changing the theme in Look & Feel , the tabs of the Preferences menu cannot be

handled properly.

Workaround: To regain normal behaviour, please restart the application. After restart, the new

Look & Feel theme remains valid. It is indeed possible to continue working with IGMAS+

particularly in the sense of calculating anomalies. But in order to apply changes to the preferences

after changes made in Look & Feel , you need to restart IGMAS+.

• Issue: When trying to use the mouse wheel or buttons, IGMAS+ seems not to respond as intended

to.

Workaround: In some cases, additional mouse software prevents IGMAS+ from working properly.

Disabling the mouse software should make the mouse buttons work properly within IGMAS+.

• Issue: If the program seems not to toggle between the sections in the 2D view when you are pressing

the PageUp or PageDn :

Not a bug: Probably the view tab is not active. Point the mouse over the view tab and click the left

mouse button.

• Issue: The clipping planes slider sometimes only responds on a second try.

Not a bug: When you move over from a different part of the window, e.g. from the view or model

tree, the first click on the slider activates the slider’s window section. The slider itself is then ’grabbed’

with the second click and move.

• Issue: Uncaught Exception - this error message occurs occasionally on Windows XP systems after

opening a file browser. The reason is unknown yet, however, it seems not to have any impact.
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Workaround: Not necessary, just ignore it (click Close), the program continues normally.
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Control, 54
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Model, 60
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Cursor tracking, 27
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absolute, 78

Body, 106

effective, 105, 106
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Exaggeration
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Exit, 29

Export, 28
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error, 45

properties, 44
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File, 28
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import, 70
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Gravitational constant, 122

Gravitational potential energy (GPE), 115

Gravity

constant, 122

field, 44

gradient, 44

invariants, 44

Gravity meter, 43

Grid

cells, 69

points, 69

Hayford ellipsoid, 129

HDT, 124

Heap, 16, 32

Horizon

oversampled, 70

Horizontal directive tendency, 124

Horizontal gradient, 124

Import, 28

Project, 68

Info-light, 27

Installation, 17

Interface, 28, 38, 75, 95

export, 132

Interpolation

Average, 111

Mundry, 71, 111, 124

Nearest Neighbor, 111

Invariants, 44, 124

algorithm, 124

Inversion, 108

Isostasy, 119

Isosurface, 19

Java Runtime Environment (JRE), 14

Java SE, 14

Java Virtual Machine (JVM), 14, 16, 32

Kilometers, 128

Layout, 26

License, 21

Wizard, 35

Linux, 13, 67

Load

Model, 67

Log, 34

log file, 35

Mac, 13, 19, 21, 23

Magnetic

field, 44

Mass Points, 125

Memory (RAM), 16

Memory status, 27
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Menu

Help, 33

Research, 32

Tools, 32

View, 32

Mercator, 129

meta2xml, 67

Metadata, 73

Meters, 128

Mirror

position, 88

section, 88

units, 90

Model, 28, 46, 61

Bounding box, 47

Clipplanes, 47

extension, 70

Load, 67

Save, 67

Triangulation, 63, 84

Model Elements, 38

Anomaly Fields, 44

Body, 38

Interface, 38

Polygon, 41

Sections, 39

Stations, 43

Multicore, 123

Nafe & Drake, 107

New

Project, 66

No_data_value, 120

Node, 86

Object Tree, 27, 37

OpenCL, 16, 19

Point Mass, 112

Prism, 112

Triangle Kernel, 123

OpenJDK, 14

Options, 31

Language, 31

Look&Feel, 31

Oracle JDK, 14

Orientation

change, 138

triangulation, 138

out of date (o.o.d.), 12

Parallel view, 51

Pascal’s law, 113

Perspective view, 51

Physical parameters, 76

Plugins, 19

Cluster, Cloud computing configuration, 142

Marching Cubes, 126

Scripting, 58

Voxel vectorization, 126

WorldWind, 56

Point masses, 111

PointSet, 29, 67

import, 73

Polygon, 86

combining, 81

Preferences, 23, 29

Selection, 29

Pressure, 113

lithostatic, 113

Progress bar, 27

PROJ.4 Definition, 131

Project, 28, 66, 67

Close Project, 28

Import, 68

New Model, 61

New Project, 28, 60, 66

Open Project, 28, 67

Save Project, 28, 66

Project file, 68

Property editor, 27

Reference body, 75, 76, 88

Reference density, 75, 115

Remanent, 101
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Report

error, 12, 35

system, 35

Requirements

Software, 13

Save

Model, 67

Project, 66

Scale Z, 45

Scripting, 19, 58

Sectioning, 92

direction, 93

location, 92

magnetic case, 93

number, 92

Sections, 92

copy and shift, 40

direction, 71

distance, 71

mirror, 88

name, 40

remove, 40, 93

SEGY, 19

Seismic velocity, 107

Set body(s), 83

Shift value, 45, 78

Shortcuts, 59

Software Requirements, 13

Spherical, 19

Standard deviation, 45

Station

elevation, 43, 119

elevation offset, 43

file format, 136

load, 136

position, 43

projection distance, 43

save, 136

topography, 43, 119

Stations, 28

Stereo, 16, 51

Stratigraphy, 69

Stress, 19, 113

anomalies, 115

export, 119

horizontal, 114

normal, 113

settings, 116

vertical, 113

voxel, 118

Strike direction, 71

Susceptibility, 75, 76, 95

function, 106

variation, 77

System, 16

report, 35

Theme, 31

Time Machine, 11

Title Bar, 28

to be added (t.b.a.), 12

to be extended (t.b.e.), 12

Toolbar, 36

Tooltips, 54

Topography, 119

Topology, 93

Total Magnetic Field, 46

declination, 46

inclination, 46

magnitude, 46

Transparency, 50, 51

global, 50

image, 73

Triangle

normal, 126, 139

orientation, 126, 139

Triangle Calculation, 123

Triangulation, 38, 68, 69, 84, 85, 93, 126

gOcad, 138

new, 80

optimal, 80

validity, 68

TSurf, 68, 138
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Uncaught Exception, 146

Uninstallation, 23

Units, 128, 133

Unix, 13

UTM, 129

Variance, 45

Version Number, 28

Vertex

Coordinates

Input, 55

Relative shift, 55

delete, 80

insert, 80

shift, 80

Vertical exaggeration, 46

View

2D, 27, 52

Maps, 27, 56

Multiple Cutter, 27, 55

3D, 27, 50

Bookmark, 51

Center at, 50, 52

Centre Object, 52

Fit into window, 50

Head up mode, 51

parallel, 51

perspective, 51

Render, 52

Right-Mouse-Button, 51

Rotate, 50

Show Object, 51, 52

stereo, 51

Translation, 50

Transparency, 50

Zoom, 50

attach, 50, 52

detach, 50, 52

Scripting, 58

Views Window, 50

Voxel, 103

density, 106, 108, 109

export, 134

factor, 106, 108

file format, 134

import, 134

stress, 118

Voxel cube, 29, 103

Voxel model, 103

Wavefront .obj files, 140

Web Mapping Service WMS, 57

Window

About, 34

Help, 33

Log, 34

Views, 50

Windows, 13

Windows registry, 21, 23

Wireframe, 51

WorldWind, 19, 27, 56, 57, 128, 129

z-offset, 43

Zoom, 53

ZState, 42

ZTOPO, 109
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